Diamond TrackStar Information

 

    I've had a Diamond TrackStar-E Apple ][ emulation board for a while now, but never had the chance to install it. Well, I began the process at the end of April 2001 and I experienced a high level frustration because weaving together the random information available just wasn't working.

    So, in an effort to help others similarly situated, here is a zip file containing several versions of the TrackStar drivers, a copy of the latest csa2 FAQ on the TrackStar and a PDF of the installation and operation manual, courtesy of Bart Prine. The archive file also includes several disk images that I have found useful in the short time I've been using the TrackStar.

    Anyway, here are some basic informational items and random tips as to how I got mine to work.:

     Update 5/18/01. For several days now, I've been trying to get several COMM programs to work on the TrackStar. Don't you know, there's a comment in the manual that says that most COMM programs will not work with the TrackStar. How bogus! They went through all the trouble of precisely emulating an Apple //e and couldn't make COMM programs work. Not only that, but the old IN#2 trick to transfer a text file (containing a BASIC program) to the Apple from a PC using a null modem connection doesn't work either. I was forced to dig out the "real" ][+ that I have and use ADT on that. If you need a utility to transfer DSK disk images from a PC to an Apple, use ADT. Get it on any Apple mirror site.

    Update 4/28/01. I originally thought that the reason why the TS began working is that I put a ROM image into the TS directory. After some additional research I've found that this is a red herring. The TS already contains an Apple ROM (written by Language Arts). It seemed that the TS would boot from an Apple diskette in the Disk ][ drive attached to the TS, but not an APP disk image loaded through the TS unless it's handled in a certain way.

    When you create an APP file, you need to format it in order to use it. I assumed that if you use the TrackStar TSUTILIT program (which performs a track-by-track copy) that it would "format" the disk automatically as part of the process. It doesn't appear that this is the case. The only way I was able to get a new disk image to work was to create a blank APP file, boot with a DOS 3.3 disk, INIT the APP file and use COPYA to copy all of the files to the image. This new image is bootable and otherwise works perfectly. I used a similar procedure to create a working ProDOS disk image.

    I have to say that the TrackStar manual has a lot of good information in it, but for 60 some odd pages, it under-covers a few key topics such as the above.

       This is a nifty product. It's a shame that it didn't catch on, but I suspect that the nearly $500 price tag had something to do with it.

-- Rich

 

Copyright (c) 1998-2016 Richard A. Cini, Jr. (rcini at msn dot com) All Rights Reserved. All copyrights of any third parties referred to herein are hereby acknowledged. There is no warranty, either express or implied, relating to any of the content contained herein. The site maintainer shall in no event be liable to anyone for damages, including any loss of profits, lost savings, or other incidental or consequential damages arising out of the use or misuse of the information contained on this Web site. Batteries not included. You may use the information contained herein for NON-COMMERCIAL purposes only and AT YOUR OWN RISK.

Last Updated 02/20/2016 18:00 -0500