Starting over with 8" drive on PC

Randy McLaughlin cctalk at randy482.com
Fri Mar 25 23:13:17 CST 2005


From: "Vintage Computer Festival" <vcf at siconic.com>
Sent: Friday, March 25, 2005 10:49 PM
> Ok, starting over here since there's been a long hiatus since the last
> time I messed around with this.
>
> I'm experimenting with different 8" disks trying to figure out what's
> going on.
>
> First, the basics: I know my controller can handle FM because I was able
> to successfully copy all the files off an old 160K PC disk in my 1.2M
> 5.25" drive.

By 160K I assume you are refering to DOS 2+ 160K MFM format using 250kbs 
transfer rate.  This absolutely proves your system can handle MFM, I could 
have guessed that without looking.

> Second, the 8" drive can successfully format/read/write an 8" drive when I
> have the BIOS configured for a 5.25" 1.2M drive.  My drive is a Tandon TM
> 848-02.  Someone e-mailed me a link to the manual they scanned, and now I
> can't find that person's e-mail nor remember who it was (I'm so sorry!)
> But at any rate, of the 3 measley links that come back from Google, I see
> that this drive is DSDD.  Still don't know if it can do FM however.
>
> I have some 8" disks in both CP/M and DOS 2.11 format from my NEC APC.
> They both read fine on the NEC APC.
>
> I'm trying to read targeted sectors using debug.
>
> With the CP/M disk, I try to L 0 0 0 1 (Load at address 0, drive 0, sector
> 0, 1 sector) and get:
>
> Not ready reading drive A
>
> Ok, so I try L 0 0 1 1 and after a longer pause get:
>
> General failure reading drive A
>
> Hmm, I'm still new to this, but this seems like a density issue.
>
> Tried on the DOS 2.11 disk and got the exact same errors on both read
> attempts.
>
> I formatted an 8" disk under DOS, then tried L 0 0 0 1 from debug and
> successfully load the sector into memory.
>
> What's interesting is if I try to read sector 0 from the NEC DOS disk and
> get the "Not ready reading drive A (Abort, Retry, Fail)" error, then
> immediately put in my known readable formatted DOS disk and hit R)etry, I
> get the same error ("Not ready reading drive A").  If I abort and then
> retry, it works fine.  Or if I wait at the Abort, Retry, Fail prompt for a
> little while then retry, it also works.
>
> Hmmm....
>
> -- 
>
> Sellam Ismail                                        Vintage Computer 
> Festival
> ------------------------------------------------------------------------------
> International Man of Intrigue and Danger 
> http://www.vintage.org
>
> [ Old computing resources for business || Buy/Sell/Trade Vintage 
> mputers   ]
> [ and academia at www.VintageTech.com  || at 
> http://marketplace.vintage.org  ]

The possible problems are innumerable.

Start by using 22disk to try and read an APC double density disk.

You can try to format an 8" SSSD disk from the PC and copy files to it. 
Make sure you are running a real DOS and not a shell from within windoze. 
Make sure you are using 22disk version 1.42.


Randy
www.s100-manuals.com 





More information about the cctalk mailing list