Specific DEC diagnostic questions (FKTG & ZDLD)

Jay West jwest at classiccmp.org
Sat Oct 21 19:11:10 CDT 2006


The /34 passes FKAA, FKAB, FKAC, ZKMA, ZQMC, - and boots RT11. So it can't 
be totally hosed.

Two diags give me odd results, and I'm not sure if they are saying something 
is failing or if I'm just not understanding what they're trying to say.

ZDLDI0 - DL-11W diagnostic - It prints the following:

CZDLDI0 DL11-W 11/44 MFM SLU
01 Devices Under Test

--------this line is the complete ascii character set (A-Z, a-z, 0-9, !-+, 
etc.)-----------

--------the above line (complete ascii character set) repeats here a 2nd 
time----------

ND PASS

The odd part is the ND PASS. Where did my E go? It thinks it ended ok, but 
something seems amiss. I tried this on a VT100, and then on an ADDS VP to 
make sure it wasn't the terminal. Both gave identical results, both set to 
8-1-N which is what the DL11 is set at. This MAY be related to the 
following...

When I run FKTGC0 (11/34 memory management excerciser) it loops on a 
character set display similar to the ZDLD diag above. But it's not the exact 
same line every time. About once every 2 seconds it prints the character set 
line, then prints it again, and this goes on for long enough that I just 
halt the processor. The only docs I can find on FKTG show a switch option to 
inhibit TTY output. I select that and run the diag again, and it just prints 
an * on a new line about once every 12 seconds. I see no documentation 
telling me if you inhibit TTY output that it's supposed to print a * every 
so often, it doesn't seem to ever stop (maybe I'm not giving it long enough) 
so I'm a bit clueless as to if it is completing this diag and * means a 
pass, or does each * mean a test phase, or does a * mean "fail"?

I'd appreciate any input on the two issues above!

Thanks!

Jay West 




More information about the cctalk mailing list