C64 ASM Question

Zane H. Healy healyzh at aracnet.com
Sat Sep 16 18:18:16 CDT 2006


>I don't know if TMA needs you to specify a starting address to assemble
>to disk; most of the hosted assemblers don't, but many of the cross
>assemblers do (xa does, for example -- I need to make a FAQ about that).
>
>Assuming it does not, SYS 4096 will run it.
>
>Assuming it does (the computer crashes), add a .byt $00, $10 above the *=
>(some assemblers will accept .word).

I'm guessing the computer crashes when I try to run it with a SYS 
4096, it puts me back at a "READY." prompt.  Adding ".byte $00, $10" 
at the beginning of the source prevents it from even compiling.

I've gone ahead and posted a question about this to comp.sys.cbm as well.

On a positive note, I *FINALLY* found my Wico Command Control 
joysticks, and the Atari 2600 sticks!  Based on the box they were in, 
I don't understand how I missed finding them a couple weeks ago when 
I pulled the C64 out.  Also found the Power Supply for the A500, and 
the 2002 monitor cable, so I'm about to see if the A500 still works 
:^)  Now where did I put the copy of Overlord/Supremacy for the A500 
:^)

			Zane


-- 
| Zane H. Healy                    | UNIX Systems Administrator |
| healyzh at aracnet.com (primary)    | OpenVMS Enthusiast         |
| MONK::HEALYZH (DECnet)           | Classic Computer Collector |
+----------------------------------+----------------------------+
|     Empire of the Petal Throne and Traveller Role Playing,    |
|          PDP-10 Emulation and Zane's Computer Museum.         |
|                http://www.aracnet.com/~healyzh/               |



More information about the cctalk mailing list