RL02 Fault, not where you might suspect it

Charles charlesmorris at hughes.net
Fri Jul 13 14:11:51 CDT 2007


I'm back from vacation (a wonderful time, except that for a week
in mid-June southern Europe had an amazing heat wave - 43C/109F
during the day in SW Crete, overnight lows around 33C/92F. Rumor
has it that Athens saw nearly 50C/122F!).

I have resumed work on my 8/A - RL02 - OS/8 system that booted
only once (on the second power-up a buffer on the M8315 CPU board
which drove memory address bit 4 failed). I'd previously posted my
adventures finding that 74367.

Anyway having fixed that it still wouldn't boot. The drive would
load and the READY light would illuminate, indicating that track 0
had been located. When flipping the BOOT switch, the head could be
heard to move, then the FAULT light would go on and the boot
loader would hang. I did find that the disk pack had developed a
bad block at octal 100, so I remade the image on a new pack with
no bad blocks. Same error. So I put the pack in the drive that
made it (on my PDP-11/23+) and ran the cable over to the
controller. Still no go.

I keyed in a couple of short programs and couldn't read the
Command Register B properly. Sending one (or a loop of) reset
commands (6600 octal) to the drive did not cause the FAULT light
to go out - only power cycling the RL02 would clear it. That told
me the controller was not communicating with the drive at all.

With a few more test programs and the controller on an extender
card, it was easy to see that the reset command was not being
received, although the IOT 660x signal was. It turned out that the
TP3 signal (required for the reset, among many other functions)
was low in amplitude, barely 2V at the Omnibus pin CH2 (the other
CPU timing pulses TP1,2,4 are well over 3V). The input buffer on
the controller card was not responding to this weak pulse. 

Working backwards, I arrived at the source (E27-6 on the M8315
CPU, a 74120 Pulse Synchronizer). There's a pair of these,
E22/E27, driving TP1..4 onto the Omnibus. Nothing obviously fried,
but the other three outputs showed about 750 ohms to ground (on my
Fluke 73) and the defective one was 57 ohms. Before desoldering
the entire chip I confirmed it was defective by lifting pin 6 and
it still had very low resistance.

So the source of the RL02 FAULT is apparently a bad driver chip on
the CPU board. Not where I would have first suspected it. There
may well be yet another bad chip, but one error at a time... now I
have to lay hands on a 74120 before my next 4 week trip away from
home (leaving Sun. 22nd).

Would anyone have one or two 74120's that you could drop in the
mail tomorrow (I'll be happy to pay for the chip and postage), or
point me to a supplier? Neither Mouser, Digikey, Jameco nor Newark
have them :( and Unicorn Electronics has a $20 minimum order.


thanks for any help
-Charles





More information about the cctalk mailing list