TRS-80 Model 1 vs Model III disk/application compatibility question

Tony Duell ard at p850ug1.demon.co.uk
Tue Jan 27 13:14:14 CST 2009


> 
> Hi, all,
> 
> I was cleaning up around the house and wanted to stash a Model 3 on
> the shelf out of the way.  Before I did, I fired it up to make sure it
> (still) worked, and to try something I haven't tried before...
> 
> I have diskettes, c. 1982, from a friend lying around, so I booted it
> into TRSDOS 1.3.  All seems well.  It claims to have 48K (internally
> and according to the markings of the case and the memory report at
> boot time), passes MEMTEST (which is on most/all of the TRSDOS disks),
> it runs BASIC, and it starts a couple of binary games I found.  What
> it does not do is run Zork or Enchanter.
> 
> I have original Zork I and Enchanter disks.  Booting up a backup of
> the Zork disk gets me to a TRSDOS prompt.  I can take a DIR and see
> the program and the data file there.  If I start Zork, the screen
> blanks, the disk gronks and the access light blinks occasionally.  I
> hear what sounds like successive track seeks (which I'm expecting
> since I know how Z-Machines work and roughly what virtual pages need
> to be loaded to get a game started), but then after a few seconds
> (less than 2 min), it sounds and looks like it's in a loop and repeats
> the gronking and flashing.  I never see anything on the screen except
> for a blinking cursor.  The Enchanter disk isn't much better - I think
> it spins the disk and gronks for a bit, then goes quiet.
> 
> I'm posting because I am reasonably certain, due to age if nothing
> else, that these are Model 1 diskettes.  Enchanter is a flippy, with

As far as I rememebr, a Model 3 will not boot any Model 1 disk (or of 
course vice versa). There have been disks that were made to boot on both 
machines, by having a mixture of single and double density sectors on the 
boot cylinder IIRC, but no nornmal OS will boot that way.

So the fact that the disks boot to a TRS-DOS prompt implies they're M3 disks.

I have Zork 1 for my Model 1. It was a self-booting disk, no TRS-DOS or 
similar. And it was copy-protected (nothing that SuperUtility couldn't 
manage :-)). So again, it sounds like you have a Model 3 version,

Since the system will boot other disks and run other programs, I susepct 
either an unreadable sector on these games disks or something marginal in 
the disk drive or disk controller. 

Have you tried to make a ackup of Zork and/or Enchanter? If so, do the 
backups behave inthe same way?

-tony




More information about the cctalk mailing list