apple Lisa2. One working!! - one to go?

Ray Arachelian ray at arachelian.com
Fri Dec 10 19:49:59 CST 2010


On 12/08/2010 04:47 PM, Terry Stewart wrote:
> Tony (and anyone else interested),
>
> Here is the symptom on this Lisa 2/10 (or Mac XL as they are also
> called sometimes).

XL just stands for Ex-Lisa.  Apple tried to imply Extra Large, as in it
looks 2x as wide as a Mac 128, but insiders have mentioned Ex-Lisa
repeatedly.

>
> It passes all tests until it gets to the I/O board test.  It then
> fails with an error 57 message (disk controller fault).  Reading Lisa
> 2 documentation suggests this is the Lisa Lite adaptor, but with a
> Lisa 2/10 there is no such thing. The floppy disk is connected
> straight to the I/O board.  I am not sure if the fault is on the I/O
> board itself, or somewhere on the Widget hard drive controller?   I've
> found the schematics, but no real "theory of operation" docs for the
> widget drive itself.

Right, that board is needed only by the Lisa's that have a battery pack
on the I/O board.

>
> The Lisa allows you to click on both the hard drive icon or the floppy
> drive icon even after the error is posted.  Neither work.  The hard
> drive comes up with an error 82 which means "Drive doesn't answer".  I
> can't recall right now what the floppy error is, but it doesn't spin
> up or eject, even with a DD drive.

Might just need an OS installed, which of course you'd need to fix the
floppy issues for.  There's a wonderful test suite called LisaTest, but
of course, it's useless without a working floppy system.

Check the obvious first, make sure the floppy cable isn't inserted
backwards, etc.  Try swapping the floppy drive to your other working
Lisa to see if it works there.   At least that way you can eliminate it,
though your symptoms are obviously not the drive itself.

>
> I suspect the fault is on the I/O board itself as the floppy seems
> dead even when the hard disk is disconnected.  However, I'm not
> assuming anything. This may be just because the I/O has reported an
> error, or it's functionality may need the widget drive to be on-line.
>
> Some other things...
>
> 1. With the widget and floppy drive unplugged, the same error occurs
> (but this might be because they ARE unplugged).  The error also occurs
> with either one or the other plugged in
>
> 2. When I switch on, the widget drive spins up, the drive light
> flashes and I "think" I can hear the "clack" people write about when
> the brake is released.  It's quite noisy but I believe these drives are.
>

It's perfectly normal for Widget (and ProFile) drives to take upto 5
minutes to become ready.  On powerup, the drive starts scanning for bad
sectors.  The drive light is a "ready" light.  That is, the LED turns
off when it's active (or flashes) and turns on steady when it's ready to
go.  The fact that you're seeing this behavior is a good thing.  But 82
means the drive isn't answering, could be a Widget controller issue.

http://lisafaq.sunder.net/index.html#lisafaq-hw-hd
http://lisafaq.sunder.net/lisafaq-hw-rom_error_codes.html

> 3. I've cleaned all the card edges.
>
> 4. I'm fairly sure I have the right ROMS.  The machine reports H/E8. 
> H is correct for the Lisa 2/10.  E8 (which refers to the floppy disk
> routine I think) is not documented anywhere.  88 seems more common. 
> It may be a later revision.

I've never heard of E8.  It's either 88 or A8.  It may be that you have
one that has the 800K floppy hack ROM, though, no one has reported those
has having a different ROM version, is your monitor ok, are you perhaps
misreading A8 as E8?  If not, it could be the ROM might be corrupted.

Looking at the boot ROM source, 57 actually means:
"57 = bus error accessing disk controller"

This means that the Lisa ROM attempted to access the 6504 when the 6504
was busy.  There's a signal that prevents the 68K CPU from accessing the
floppy RAM while the disk controller is busy.  If it tries, it gets a
bus error.  This is the DISKDIAG line.  There's another bit of code
where if DISKDIAG is held too long, it will issue the same exact error. 
Either way, something's wrong with the 6504 disk controller circuitry
somewhere.

So more than likely, something is wrong with your I/O board, possibly
the ROM, RAM, or 6504 CPU are bad.  If you can, find another I/O ROM, I
think you'll want version 88 for the Lisa 2/10.
If you're able to locate the ROM dumps and burn your own EPROMs, that
might be another option, it would at least be something to try.  The ROM
is socketed, and usually labeled with a sticker that has the version
number and says "Copyright Apple" somewhere ot.  Check the label on it,
I'm guessing it would say 88.  If you actually see E8, you might want to
get a dump of it as it's unknown to me, and might be useful.  If you see
SunRem or Sun Remarketing or anything like that, that might be the 800K
ROM instead.

88=10001000
A8=10101000
E8=11101000

So that's a single bit difference if that ROM was supposed to be A8, but
AFAIK, A8 shouldn't be in a Lisa 2/10, that should be 88.  Or we could
have random corruption on the ROM, it would make sense that DISKDIAG is
held locked if this is the case.  The shared RAM can also be an issue,
as could the IWM chip.  It would be great if you had a spare I/O board
for the 2/10, because at least you could swap the socketed chips back
and forth to see what it might be.  A known good board to compare
against would be helpful.  But if you don't, I'd try to get a
replacement 88 ROM, if that doesn't work, try replacing the RAM chips. 
A spare IWM would be impossible to find - you'd need another 2/10 I/O
board for that.

Hmm, you might be in luck:
http://www.vintagemicros.com/catalog/index.php has I/O ROMs in stock,
sadly, no whole I/O boards, but if it is the ROM, that's a very easy fix.


You might also want to ask about this on the LisaList as there are a few
very knowledgeable Lisa HW folks there that aren't on here.
http://groups.google.com/group/lisalist?hl=en_US

Let me know if you find anything interesting so I can add it to the LisaFAQ.




More information about the cctalk mailing list