Software for small-memory PDP-11s?

Josh Dersch derschjo at
Sat Nov 14 12:48:55 CST 2015

On 11/14/15 7:07 AM, Jerome H. Fine wrote:
> Sorry I forgot to remove the SPAM  KEY notice thsat my e-mail places 
> there!!!!
> >Paul Koning wrote:
>>> On Nov 13, 2015, at 5:45 PM, Josh Dersch <derschjo at> wrote:
>>> Hey all --
>>> Now that I have my PDP-11/05 running nicely, I'm curious what others 
>>> are
>>> running on small systems like this -- until this point I've only played
>>> with larger (i.e. at least 28KW memory) systems.  I have only 8KW of 
>>> memory
>>> (with no viable options for expansion) and there's not much out 
>>> there that
>>> I've found.  There's paper-tape BASIC (which is always fun) and 
>>> FOCAL, and
>>> PTS-11 ( which is 
>>> pretty cool
>>> if a bit cumbersome.  Any other suggestions?
>>> I'm also curious if any version of RT-11 that supports the TU58 
>>> could be
>>> made to run on this system -- I have two SLUs in the system so in 
>>> theory I
>>> can boot from an emulated TU58. However RT-11 4.0's SYSGEN manuals 
>>> suggest
>>> that 12KW is the minimum supported (and experimentation bears this 
>>> out) and
>>> I can't find much in the way of manuals for RT-11 V3B -- which I 
>>> believe is
>>> the earliest version with TU58 support.  (V3B seems to be different 
>>> enough
>>> from later versions that I'm not quite sure how the SYSGEN process 
>>> works.)
>> RT11 V2 SJ will certainly fit easily in that size memory.  DOS will 
>> fit even in 4K (at least the older versions).  Come to think of it, 
>> RT might also; I haven't tried it that small.
>>     paul
> NOTE:  I don't have a real PDP-11/05.  All my tests
> were done under Ersatz-11.
> I just tried to boot V04.00 of RT-11 on a PDP-11/05
> using an RK05 device (RK:) under the RT11SJ.SYS
> monitor.  First I set the memory to 32 KB (16KW)
> and it worked quite well.  Then I tried with 16 KB
> (8KW) and while it did boot, during the boot process
> of V04.00 of RT-11, I did see the error message:
> Insufficient Memory
> On the other hand, I was able to perform a DIR
> and a few other tests which did work.
It's interesting; I tried the same thing and while it worked under simh 
booting from RK05, when I tried it on the real thing (after changing the 
boot device to DD:) it fails with:

"?BOOT-U-Insufficient memory"

And halts.  I'm unsure what would cause the discrepancy; simh doesn't 
appear to support the TU58 for the PDP-11 so I can't verify, but perhaps 
the DD: driver requires more memory.  (And yes, I've tested the 8KW 
memory in the 11/05 extensively, it's all there and working :)).

> I then attempted to confirm with V2 and 16 KB of
> memory and that also worked with the RK05 device.
> Obviously, it is not possible to do very much with
> just 16 KB (8KW) of memory.
> As for support for the TU58 device (DD:), I also
> attempted that and came up empty. using V3B
> of RT-11.  The V3B distribution which I have
> does not seem to support the TU58 since RT-11
> crashes when I attempt to use the TU58 device.
> There may be some bad code in RT-11 when the
> TU58 is used with a PDP-11/05.  I just don't have
> the resources in the time that is available to find out.
> Josh, you don't mention if you have a disk drive
> of any kind on the PDP-11/05,  It would help
> if you could describe all of the available hardware.
> If the TU58 is the only "disk drive" available, then
> I am not sure what to suggest in order to get RT-11
> to run in any case.

What I have available (that will work/fit in an 11/05 lacking a UNIBUS 
expansion chassis) are two SLUs and an RX02 controller.  I was hoping to 
bootstrap over TU58 and then see what I can do to get a system running 
off of the RX02 (which will require V4.0 for the DY: driver).

It might just be easier to build an RX02 image on simh and try copying 
it to the '11 over the SLU.  Have to cobble some code together to do that...

- Josh

> Jerome Fine

More information about the cctalk mailing list