Resolved: VAX-11/750 ECKAL (Cache/TB) Diagnostic failure

Josh Dersch derschjo at
Thu Apr 21 22:15:46 CDT 2016

Hey all --

I resolved the weird failure I was seeing on my 11/750 with the Cache/TB 
diagnostic and since it was fairly random I thought I'd share it to save 
people from the future (hi, people from the future!) from going through 
the same machinations I did.

Issue:  ECKAL diagnostic loads, prints banner and halts after about a 
second with:

00003488   06

No other diagnostic is provided, and since there don't appear to be any 
listings or real documents covering the test, it's not particularly helpful.

What I tried (prior to tonight):

- Checked voltages.
- Double-checked backplane for bent/shorted pins.
- Cleaned and reseated every socketed chip (especially the gate 
arrays).  On *all* boards.
- Swapped in a spare L0003 (after cleaning, as above).
- Swapped in all the other spares I have (one at a time, again, after 
- Cleaned backplane with contact cleaner.
- Removed 2nd UNIBUS card.
- Tried a *third* L0003 card (labeled "GOOD" as of 1996 :)).

No change in behavior whatsoever.  Very odd.  Very frustrating.

So tonight I thought, hey, why not disconnect the UNIBUS just in case 
something odd is going on there.  Pulled the Unibus jumper connecting 
the two backplanes, replaced with terminator.

ECKAL diagnostic now runs and passes.

So:  This particular fault (at least in this case) is due to some oddity 
on the UNIBUS.  I suspect a problem with NPG grants, but I'm going to 
have to go over this with a fine-toothed comb, it could be a bad 
controller in there doing something mean.

Hope this helps someone at some future date...
- Josh

More information about the cctalk mailing list