Tektronix 6800 'Developer Computer'

Brad H vintagecomputer at bettercomputing.net
Thu Aug 4 11:25:26 CDT 2016

Hey guys,


In addition to that 6800 SWTPC I got, I also picked up this 'board bucket'
from ebay:


veloper%20Computer?sort=3&page=1> &page=1


It's a 6800 system of sorts and has BASIC and 'DDE' ROMs.  I've tried
hooking it up to a terminal but no response.  I think the system isn't fully
running.    This is a video I took:




Hard to see with the camera, but when you hit and hold reset the little
display looks sort of normal.  When you release, it's like some of the
segments are half-on rather than fully on or off. I tried pulling RAM boards
and such but no action yet.  Step button on the CPU card doesn't do


If anyone has seen one of these or has any ideas on getting her working, I'd
be most interested.  I sent an email to Tektronix to inquire about it as
there are part numbers and stuff on the boards.   Hopefully they can answer





More information about the cctalk mailing list