6800 memory addressing

Brad H vintagecomputer at bettercomputing.net
Sun Aug 7 01:56:14 CDT 2016

So I have the 6800 almost fully working, however I've hit one snag.  
I loaded some of the memory diags as a first test, from txt files posted online.  The first couple worked ok, but the third kept hitting an error immediately on start.  
I thought little of it and was eager to try a bigger program.  I tried Blackjack.  However I noticed when it was loading.. instead of just the cursor remaining beside my L until loaded, it began dumping random stuff out.
So that's when I went back to that RAM test.  I noticed it has having the same issue with a certain range.  I realized then that my single RAM board was only covering from (I think) A000 up to but not including C000. 
So I used the jumpers on my DRC 16k boards to fill in the blanks, so to speak.  But I'm stuck on the last one.  The memory check now crashes at address 8000.  Because my last MPM board was modified, I'm not sure how to get that particular range.  I'm also wondering why I only get from A000 to C000 on my other MP-M board.  The 16k boards can be set for wide ranges.. say 8000 through I think FFFF (can't look at the docs as SWTPC.COM went down tonight).  I'm assuming the smaller RAM boards cover less?  With three of the four installed, I can load a program via txt file without error but cannot run it.. if I hit G it just freezes there.  So I'm not sure if I need to configure a ram board for $8000 up to $A000 or if I potentially have another problem.  And because the MP-M boards are both modified.. I don't know what they are/were set up to do.

Sent from my Samsung device

More information about the cctalk mailing list