TU58 problems

tony duell ard at p850ug1.demon.co.uk
Sat Jan 16 11:44:27 CST 2016

I am not sure this fits in with the current topics of this list on the grounds it involves
real old hardware, but anyway..

I am currently trying to restore a VAX11/730. I got this about 20 years ago and 
dismantled it to get it home. For various reasons I never put it back together, I
am doing that -- slowly -- now.

It's the version in the half-height rack with an R80 at the bottom, then the 11/730
CPU box, and a TS05 on top. I know I am going to have problems with the storage
devices, for the moment I am jsut trying to get the CPU running. I've remounted it
in the rack, got all the ribbon cables in place, tested the PSU, etc. Minor PSU problems
(leaky transistor) but now fine.

Powering up gives the expected ROM> prompt on the terminal. Of course all you can
do at that prompt is load the microcode from the TU58, so that is what I am trying to
get working. And getting nowhere!

Firstly the TU58 controller is not passing the self-test. I am pretty sure the 8155 RAM/IO
chip is dead. I have removed this and fitted a DIP socket.

The rollers were of course dead. I have made hubs and fitted an O-ring of a suitable
size. This may not work correctly, but it does seem to move the tape. I have a couple
of tape cartridges, the Console microocode tape, and amazingly the belt seems good
in them. The motor does get the tape whizzing past the heads.

 I tried an 8155 borrowed from another device. The controller then passes the self-test
(the LED comes on and stays on) but all I get is DD1: Read Error messages and the tape
often runs off the spool (rethreading it is something I've got quite good at!).

I tried a RS232 analyser between the TU58 and the VAX. Very odd. Either my RS232 anaylser
drops 00 bytes or the TU58 sets short result packets. The meaningful bytes (response code, etc)
are there, but things like the sequence number are not. Odd...

With the 8155 removed, I can pull port pins (on the socket) high and low to start the
motor, select drive, track, direction, etc.

I've done that and put a LogicDart on the output of the comparator in the read amplifier.
According to the manual, the tape is recorded at 800bpi and runs at 30ips. So I get that
a bit should take around 41us. And a bit starts with a rising edge, the position of the falling
edge (recorded at 1/4 or 3/4 of the bit time) determines whether it's a 0 or 1. 

Well, sometimes that's what I see on the LogicDart. Sometimes I see a 1:1 square wave with
a period of 40-odd us. 

Does anyone have any sensible ideas as to what to try next. At the moment I have no idea if
it's the tape, heads, roller or what....


More information about the cctalk mailing list