TU58 problems

Mattis Lind mattislind at gmail.com
Sat Jan 16 13:59:39 CST 2016

Some comments inline. Mostly is maybe obvious...

2016-01-16 18:44 GMT+01:00 tony duell <ard at p850ug1.demon.co.uk>:
> Powering up gives the expected ROM> prompt on the terminal. Of course all
> you can
> do at that prompt is load the microcode from the TU58, so that is what I
> am trying to
> get working. And getting nowhere!

And you don't want to use a TU58 emulator? (Or you enjoy waiting for the
TU58 loading the microcode :-)

 I tried an 8155 borrowed from another device. The controller then passes
> the self-test
> (the LED comes on and stays on) but all I get is DD1: Read Error messages
> and the tape
> often runs off the spool (rethreading it is something I've got quite good
> at!).

If it run the tape off spool the system seems to be unable to detect
EOT/BOT markers on the tape.
and since the TU58 is only relying on the read signal for this there has to
be some problem with how the tape is read.

> I tried a RS232 analyser between the TU58 and the VAX. Very odd. Either my
> RS232 anaylser
> drops 00 bytes or the TU58 sets short result packets. The meaningful bytes
> (response code, etc)
> are there, but things like the sequence number are not. Odd...

Indeed, very odd. Since it now passes the self test I assume that the
firmware is OK so it has to be something else. How can it miss sending
bytes? Could there some problems with the interrupts? The RST 5.5 and RST
6.5 signals from the UART to the CPU. Or is there a subtle problem with the
CPU itself in this respect. A logic analyzer on the bus and the interrupt
signals would probably tell some. The 8085 code in the ROM would be easy to
disassemble. If this isn't already done. I think I remember seeing a
disassembly somewhere?

> I've done that and put a LogicDart on the output of the comparator in the
> read amplifier.
> According to the manual, the tape is recorded at 800bpi and runs at 30ips.
> So I get that
> a bit should take around 41us. And a bit starts with a rising edge, the
> position of the falling
> edge (recorded at 1/4 or 3/4 of the bit time) determines whether it's a 0
> or 1.
> Well, sometimes that's what I see on the LogicDart. Sometimes I see a 1:1
> square wave with
> a period of 40-odd us.
> Does anyone have any sensible ideas as to what to try next. At the moment
> I have no idea if
> it's the tape, heads, roller or what....

The indication of the strange read signal probably explain why it runs off
the spool. Does both TU58 drives behave the same? If they do it would of
course point towards the TU58 controller. A scope probe on the previous
amplifier stages show what kind of signal? It is not some kind of fault
with the tape write circuitry? So that this is somehow enabled due to a
logic fault?

Does the "Tacho" signal show the correct speed?

You don't happen to have another TU58 controller to try with just to verify
things. I have quite many of those actually.

So no real answers since I always cheated when it comes to TU58: I use an


> -tony

More information about the cctalk mailing list