AJRLADO diskless controller test

David Gesswein djg at pdp8online.com
Fri Jun 3 21:02:22 CDT 2016

On Fri, May 06, 2016 at 09:47:47AM +0200, Anders Sandahl wrote:
> Hi,
> I tried to run the diskless controller test on my PDP8/A. It fails before
> any tests has been executed. I suspect that my RL8A controller is broken.
> The CPU tests and the memory tests works fine.
> The test stopped @ address 5713 (display shows 5714), MD buff = 7402, AC = 0
> Does anybody have the source code to this test? Earlier someone got the
> test instructions photographed from microfishie.
Hopefully you got it fixed by now. I had misfiled the fiche and took me
a while to find it.

Looks to be a power fail fault.

I have added the relavent pages to 

Seq18 is where you can see the interrupt jumps to PWRFAL
Seq75 is PWRFAL where it checks that the interrupt is a power fail and then
halts waiting for a power up restart.

> The complete story is that the machine worked just fine, booted OS/8. Then
> I changed the CPU from KK8A -> KK8E. The KK8E had some problems, but works
> fine now. But now the machine doesn't boot OS/8 with any of the CPU's. The
> diskless controller test stops at the same location with any CPU.
Do you have a KP8E power fail installed? I would think with a KK8E without
KP8E that you shouldn't get to that halt since the SPL shouldn't skip
so it will go to impossible interrupt.

You can look at memory location 0 to see where it was executing when it
got the interrupt.

More information about the cctalk mailing list