SWTPC 6800 weirdness

Brad H vintagecomputer at bettercomputing.net
Tue Sep 6 16:01:04 CDT 2016

-----Original Message-----
From: cctalk [mailto:cctalk-bounces at classiccmp.org] On Behalf Of william degnan
Sent: Tuesday, September 6, 2016 11:37 AM
To: General Discussion: On-Topic and Off-Topic Posts <cctalk at classiccmp.org>
Subject: Re: SWTPC 6800 weirdness

On Tue, Sep 6, 2016 at 2:25 PM, Brad H <vintagecomputer at bettercomputing.net>

> My 6800 has been mostly working, but it seems to be occasionally 
> flaking out.  I don't know why.  Sometimes you go to power it up, and 
> there's no response on terminal side.  The 'fix' is sometimes to 
> wiggle the memory/CPU boards and then for some reason it's fine(ish).  
> There are five cards installed right now - the MP-A, MP-S, a heavily 
> modified MP-M board (with rams piggybacked on all the original RAM 
> chips) and then two Digital Research 16k boards.  The system was 
> modified for Flex 2.0
> Today it flaked again and would not come back up, so I pulled the MP-M 
> board and the MP-A board and swapped slots.  It came up, but memory at 
> $0100 was
> missing.    I tried powering up, swapping slots, etc.. same deal.  Then I
> left the machine for an hour, powered up again.. boom.. now $0100 is back.
> I don't fully understand the addressing system but if that MP-M is 
> configured as $A000 would that cover $0100 as well?
> I've tried changing the jumpers on each of the DR 16k board to cover 
> $A000..
> but the machine will not boot.  I will only work with either the MP-M 
> alone or those 16k cards with it configured to other spaces.  In other 
> words, the machine does not accept any other card configured for $A000.
> I'm wondering if anyone has any suggestions on how I might nail this down.
> I'm thinking some of the RAMs on that MP-M are flaky, but it would be 
> a
> *nightmare* to try and diagnose it, with all the RAMs piggybacked, all 
> the little jumper wires, and everything soldered.  I'd prefer to 
> bypass it and either use my other, less modified MP-M or just the DR 
> boards, which are socketed.  If any of you have suggestions on how I 
> might take this MP-M out of the equation that would be awesome!
> Brad
>You'll need to make electrical measurements, from the system checkout in
>the manual.   You very possibly will have marginal components that need to
>be replaced, but it's best to try to locate which is bad rather that to replace at random.

>A000 is not the same place as 0100.    In the 64K space, they're quite

>Eliminate all but the one RAM board, setting it to 0000.  Test that thoroughly, then add the next at the next RAM space beyond the first card.
>Continue until you have enough RAM for a minimal Flex boot.  It should tell you in the version of Flex you're using how much that is (24K?)  It's hard to do everything at ?>the same time, break it down into chunks..

Thanks Bill.  I've tried working with just single RAM boards, but like I said, the only one that will work at all is this modified board.  I have pics of it here:


If I could understand better what it is set up to do, what address spaces its occupying, I might be able to understand why my 16K DRC boards don't work when I try to put them to $A000.  I'd prefer to work with one of those boards first since the chips are socketed, and then I could test the chips individually and be sure one whole board is good.

I note in one of my pics there, the cap on that modified MP-M looks a little tarnished on the outside...

More information about the cctalk mailing list