Recovering 4mm tar tapes

TeoZ teoz at
Mon Sep 12 19:59:49 CDT 2016

What drive type are you trying to read that tape with? DD-90 is DDS-1 era 
tape and DDS-4 drives (or newer) will not read it. Also hardware compression 
might have something to do with it.

-----Original Message----- 
From: Douglas Taylor
Sent: Monday, September 12, 2016 7:35 PM
To: cctalk at
Subject: Re: Recovering 4mm tar tapes

On 9/12/2016 6:05 PM, Pete Turnbull wrote:
> On 12/09/2016 16:12, Douglas Taylor wrote:
>> I have a pair of 4mm DDS tapes from 1999 that I would like to recover.
>> I was able to read one with tar on a Debian (jessie) Linux system, but
>> the second gives an error.
>> The second tape is a 3M brand with DDS markings and 4 bars next to the
>> DDS logo.  It also has 'Media Recognition System' and DD-90 written on
>> it.  Here is the dialog and error:
>> root at T5400deb:/home/taylor/4mm_tar_1998# tar -xvf /dev/st0
>> tar: /dev/st0: Cannot read: Input/output error
>> tar: At beginning of tape, quitting now
>> tar: Error is not recoverable: exiting now
>> (None of the config jumpers were installed for the tape that I could
>> read)  Is the 2nd tape just bad and can't be read?  Or do I need a
>> slightly different tape drive?
> It could be corrupt, or it could be byte-swapped, or it could have a 
> strange block size (especially a small one), or the heads might need 
> cleaned after reading the last tape, or it might not have any valid data. 
> Does the debian tape driver support byte-swapping? Or is there a bs and 
> non-bs version?  You could try reading it with something like
>  dd if=/dev/rmt/tapedevice bs=20b conv=swab | tar tvf -
> or whatever the debian tape device equivalent is.  Does debian have some 
> equivalent to mt(1) to read/set the drive's blocksize and to move forward 
> and back along the tape?
> Personally I hate DDS/DDS2/DDS3.  I always had better luck with half inch 
> and even 8mm, and better still with DLT.
I tried using different blocksizes with no luck.  Debian does have the
mt command and I was able to use it to get the tape status, rewind and
was able to have it move the tape forward a number of records (not sure
what a record is)

#mt -f /dev/st0 fsr 10

worked.  I seem to remember from those days that the brand of tape was
critical and that you could use audio tapes (DAT).  I even tried od to
see if I could anything from the drive, no luck. I guess the cartridge
is bad.


This email has been checked for viruses by Avast antivirus software.

More information about the cctalk mailing list