EPROM baking

Curious Marc curiousmarc3 at gmail.com
Fri Dec 22 23:04:07 CST 2017

I see the same things. Some chips just won't reprogram. Symptoms include failure to program just like you, but also "chip backwards" errors. Can't remember the chip brands, I just toss them out when that happens. I have not found any way to resuscitate them. Maybe ~10% of the chips I tried had this, so rather frequent, but never any from new old stock. The failed ones were all previously programmed chips, just erased.

On Dec 20, 2017, at 6:18 PM, Mark G Thomas via cctalk <cctalk at classiccmp.org> wrote:

My stash of TI and NEC 2732s seem to have the disease, but my ST, 
Mitsubishi, and several others program fine.

In the case of a bunch of 2732s, I have tried both a vintage DataI/O 29A
programmer and a modern Batronix programmer, with the same results.
I don't think I have a programmer problem.

I still swear someone in the late 80's had me baking EPROMs in an oven
to restore their programability, but I don't remember the specifics. I 
tried a few at 450F for 15 minutes, but they still won't program.


Mark G. Thomas (Mark at Misty.com), KC3DRE

More information about the cctalk mailing list