help needed installing USB to Serial Cable for ADTPro

Raymond Wiker rwiker at
Sat Mar 11 01:30:07 CST 2017

> On 11 Mar 2017, at 06:39 , Joe Giliberti via cctalk <cctalk at> wrote:
> Greetings!
> I am trying to connect my IIc to my laptop through ADTPro and am
> having trouble getting the FT232R adapter I bought from Retro Floppy.
> The host computer is an HP Elitebook running Windows 7 Pro 64-bit.
> When I first plugged in the cable, Windows tried and failed to find
> the device drivers. I downloaded the drivers from the manufacturer of
> the chip and and ran it. It told me installation was successful and
> device manager recognized that there was a USB serial port, but
> reported an Unknown Device and a Base System Device that didn't have
> drivers installed. I tried to use ADTPro but it didn't see a serial
> port.
> Has anyone run into this issue before?
> Thank you in advance!
> Joe Giliberti

Could it be that your FT232R adapter is using a counterfeit chip? FTDI changed their drivers some time back so that they refuse to work with chips that are not manufactured by FTDI.

More information about the cctalk mailing list