help needed installing USB to Serial Cable for ADTPro

Adrian Graham witchy at
Sat Mar 11 06:24:54 CST 2017

On 11/03/2017 05:39, "Joe Giliberti via cctalk" <cctalk at>

> Greetings!
> I am trying to connect my IIc to my laptop through ADTPro and am
> having trouble getting the FT232R adapter I bought from Retro Floppy.
> The host computer is an HP Elitebook running Windows 7 Pro 64-bit.
> When I first plugged in the cable, Windows tried and failed to find
> the device drivers. I downloaded the drivers from the manufacturer of
> the chip and and ran it. It told me installation was successful and
> device manager recognized that there was a USB serial port, but
> reported an Unknown Device and a Base System Device that didn't have
> drivers installed. I tried to use ADTPro but it didn't see a serial
> port.
> Has anyone run into this issue before?

Yes, several times though like Raymond says you may be stymied straight away
if your adapter is using a fake FTDI chip. Neither of my adapters work with
ADTPro largely because of the signals I think it's expecting to get with
regard to hardware handshaking. Also they're using CH340/1 chips which are
the Chinese FTDI clones.

Recently I tried setting up a Raspberry Pi using a genuine FTDI USB breakout
adapter that gives all handshake signals but couldn't get that to work
either and resorted back to my old faithful XP desktop with real 16550 UART
which works every time.

My next idea was to get a BusPirate to see exactly what signals were in use
on the real serial port but at the time BusPirates weren't available. Now I
see they are again so I might have another look.

Binary Dinosaurs creator/curator - the UK's biggest private home computer

More information about the cctalk mailing list