SimH IBM1130 GUI appears broken

JAMES FEHLINGER jfehlinger at
Wed May 3 16:23:46 CDT 2017

One additional observation:

If I turn on throttling with values ranging from

"set throttle 100k"
"set throttle 99%"

then **all** the Win32 development versions of IBM1130.exe I've
tried, including the ones from before Jan. 29, 2016, exhibit the
behavior that I'm interpreting as "broken" -- i.e.,
the simulator never enters a "Wait" (and drops back into
the "sim>" prompt, thereby freeing up the GUI), either after
DMS boots or after a program finishes executing.

The Win32 development executables from github I've tried have
all been running on a Windows XP machine, but I also tried the
experiment on a 64-bit Windows 7 machine using the 64-bit IBM1130.exe from
a suite of SimH executables I built myself using gcc (5.1.0) under MinGW
back in June, 2015.  That 64-bit/Win 7 version behaves the
same as the 32-bit/WinXP Win32 development builds from
on or before January 7, 2016 -- i.e., correctly if throttling
is not used, broken otherwise.

More information about the cctalk mailing list