Zemu

Zane H. Healy healyzh at aracnet.com
Fri Apr 28 12:00:58 CDT 2006


> 
> I tried running Zemu in RT11 v5.3 in SIMH.
> It starts and asks for a game file. I entered ZORK1.DAT (from a zork1.zip
> I once downloaded). The ZORK1.DAT is 180 blocks.
> Zemu aborts after some 10 [ZALLOC] messages:
> [ZALLOC]: Insufficient memory]
> We didn't get memory for dynamic data. Aborting...
> [Entered ZEXIT]
> [INPEND: timer cancelled]
>  
> and then I am back at the RT-11 dot prompt.
>  
> Next I tried ".VBGEXE ZEMU".
> After a [ZINIT], three [ZALLOC] and one more [ZINIT] line, Zemu prints
> "ZEMU/RT X00.19"
> but then I return to the RT-11 prompt!
>  
> The last attempt was starting VBGEXE.SAV without a program on the startline.
> VBGEXE asks for a program, and I entered ZEMU.SAV.
> Now soem 20+ [ZALLOC] lines are printed, the last lines are the following:
> [GETSLN: returning 24. lines]
> [GETSCL: returning 80. columns]
> [GETSTP: returning terminal type 3.]
> [PUTTXT: Address = 066736, count = 14. characters]
> <[?7l<[2J,=<[r
> ?MON-F-Trap to 4 101566
> .
> 
> So, it is getting further. The "<" is actually a small arrow.
> I guess these are control sequences for a VTxxx terminal? Or NNANSI.SYS stuff,
> as the zork1.zip file contained a zork1.dat, an .exe and a Nnansi.com file
> (thus PC stuff).
> Perhaps this ZORK.DAT file is not correct ...?
> Or does the ZEMU.SAV need somethignfrom the RT-11 environment?  Zane has
> build Zemu in RT-11 V5.7, and my version is 5.3 ...
>  
> - Henk.

I'm guessing it's one of two things.  Either it needs some of the routines
that there are only stubs for, or else it doesn't like running on V5.3.  I'm
guessing either, or both have a pretty good chance of being the problem.

I'll try to find time tonight, or sometime this weekend to test it out with
the data files on V5.7.  I've got ones on my PDP-11 that I know will wor..

	Zane




More information about the cctech mailing list