Quick Forth Question

David Betz dbetz at xlisper.mv.com
Tue Jan 24 07:43:37 CST 2006


Okay, I figured out the immediate problem. Three of the pins on one  
of the EPROMs have broken off. One was hanging by a thread and fell  
off when I inspected it. I see no evidence that the pins remain in  
the sockets so I guess they must have fallen off when I removed the  
EPROMs to read them in my EPROM programmer. I suppose this suggests  
that they may have fallen off *before* I read them and that is why  
your SnapFORTH ROMs don't work. I don't think that's the case though  
because I'm sure I would have noticed that. Do EPROM (or chip pins in  
general) get more brittle as they get older? I've never had this type  
of problem before. These are gold colored (and plated I assume) pins  
if that makes a difference.

On Jan 24, 2006, at 8:28 AM, David Betz wrote:

> Well, you seem to be doing better than I am. All I can get is the  
> HHC to display "SnapFORTH" when I select it from the menu. No  
> prompt for filename and all I can do at that point is press "clear"  
> to get back to the main menu. It looks like I may have inserted the  
> ROMs in the wrong order when I put them back into the external  
> carrier after downloading the contents to send to you. Ugh! I  
> thought I had been careful about that too!
>
> On Jan 24, 2006, at 2:10 AM, Roger Merchberger wrote:
>
>> Dudez & Dudettez:
>>
>> I'm trying to get some SnapForth ROMs running for the Panasonic  
>> HHC 'puter - and I'm having a bit'o'difficulty, mainly as I  
>> know... ummm... "squat" about Forth. ;^>
>>
>> I've gotten the ROMs to be able to start SnapForth, ask for a  
>> filename, create the filename & filespace (about 1K of RAM goes  
>> "buh-bye" for every filename I make... ;-) but no matter what I  
>> type, all I get is "Can't Find xxxxx" where xxxxx seems to be any  
>> durned thing I type.
>>
>> It can't seem to make new words, and every simple "Hello World"  
>> type proggie I've found on the net makes *no* sense to the 'puter.
>>
>> It looks like it has a max. of 4-character words... duh,  
>> waitaminit... lemme check the ROMs again... *maybe* 5-character  
>> words, as it looks like the last character of the word is OR'ed  
>> with $80... It looks like it's got quite a few words, looking at  
>> the ROMs in ASCII - I found VARIA, CONST, STRIN, CVECT, JUMP....
>>
>> I could provide a clip of the ROM word table if it would help...
>>
>> I've tried:
>>
>> 100 LLL !
>> [[ To try to store the variable 100 in LLL ]]
>> 100 VAR DORK
>> 100 VARI DORK
>> 100 VARIA DORK
>> 100 VARIABLE DORK
>> [[ To try to store the variable 100 in DORK ]]
>> 100 CONS BURP
>> 100 CONST BURP
>> [[ To try to make BURP a constant of 100 ]]
>>
>> I've also tried:
>>
>> .S
>> DROP
>> ." Hello World"
>>
>> and other things I'd seen in various webpages thanks to Google.
>>
>> Anyone got any other idears for me?
>>
>> Thanks,
>> Roger "Merch" Merchberger
>>
>> --
>> Roger "Merch" Merchberger   | A new truth in advertising slogan
>> SysAdmin, Iceberg Computers | for MicroSoft: "We're not the oxy...
>> zmerch at 30below.com          |                         ...in  
>> oxymoron!"
>>
>




More information about the cctech mailing list