RK611 schematics

Gooijen, Henk henk.gooijen at oce.com
Sat Jan 28 10:09:33 CST 2006


I have done some measurements while running XXDP ZR6A??.???.
Although I cannot explain some signals I got the controller working!
 
First, the S/R flip flop E46 (UB5) gets the reset pulse on pin 1.
On the output (pin 5) is a 'continuous' pulse train, and I also see pulses
on the SET input (pin 4). So going a bit more back on the signals,
I checked the 4-input NAND E5 ... although all 4 inputs (xxx COMBINED ERROR L)
are continuous "1", I see lots of pulses on the output pin 8 ...?
Perhaps I have missed something, but as the 4 inputs are "combined" error
signals, I decided to remove the flat cable from M7904 to the bulkhead.
Don't ask me how that idea came up.
To my surprise, the diagnostic test ran without reporting any error!
 
I ran all diagnostics (ZR6A thru ZR6E) for several passes, except ZR6C
because one pass needed approx 13 minutes. ZR6D runs for approx 3:15
and ZR6E for approx 5 minutes, but all reported *zero* errors in several
passes.
 
I have not checked out that flat cable, but now that I have the printset,
I also know from the printset that the flat cable between the M7904 and
the bulkhead should be a BC06R. Also the "red stripe" is clearly indicated,
so I am 100% sure I connected everything correctly.
 
Time to connect one RK07 drive with termination on the OUT channel.
The .DIR DM0:  command still reports the same error, but "something"
happens when I enter the .INIT DM0: command.  Then I get an error as
I previously reported.  I removed the rear cover, to see the head movement.
On .INIT the head moves fast to the centre, and then back to cylinder 0.
I tried .FORMAT DM0:  Again, the 11/34 seems to be hung, but that is
*NOT* the case: I see the head make small steps (hardly visible) ...
it is no hung on the 11/34, the drive is formatting the cartridge!
Finally I get the RT11 prompt, but also a message that the formatting is
aborted due to too many bad blocks.
But is was working, so I tried .DIR DM0: ... no error now, the drive reports
0 files and some 56??? block free!  Next I copied a small program to the
RK07. The I entered .RUN DM0:HELLO, and I get "Hello world" on the
terminal! When I try to copy a big file to DM0 I get an output error,
but that makes sense.
 
I have a few more RK07 cartridges, but I will first run the other diagnostics
that use the RK07 drive.  I must thank Tony. Without his replies I probably
would have done nothing for a few weeks. Because he put some of his time in
helping I felt obligated to keep going ...
 
  thanks,
- Henk.
 
 


This message and attachment(s) are intended solely for the use of the addressee and may contain information that is privileged, confidential or otherwise exempt from disclosure under applicable law.  
If you are not the intended recipient or agent thereof responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution, or copying of this communication is strictly prohibited.  
If you have received this communication in error, please notify the sender immediately by telephone and with a "reply" message.  
Thank you for your cooperation.




More information about the cctech mailing list