PDP-8/L teletype interface

Sebastian Brückner sb at thebackend.de
Fri Mar 17 18:17:55 CST 2006


Hello everyone!

I wrote here about my PDP-8/L a long while ago already. This is my 
current status:
All instructions seem to work (only tried the simplest form, i.e. 5001). 
Core memory is mostly untested. The places I used work and retain their 
content. Examining and depositing works. AC, PC work: I can execute 
small loops using jumps and conditional skips etc.

So as far as I tried it everything seems to be alright. Now I wanted to 
revive the teletype interface to load and try more complex programs and 
that is where I am stuck now:
The machine has the M452, M706 and M707 modules. W076 was missing so I 
got a W076X from Vince that does RS232 (thanks again :-) as well. I 
don't have a real teletype. I used this small program to try and send 
characters from the switch register:

0000 7200 CLA
0001 7404 OSR
0002 6046 TLS
0003 6041 TSF
0004 5002 JMP 003
0005 5000 JMP 000

The program loops like crazy but nothing happens to the serial output. 
If I connect a oscilloscope to the data lines of the M707 I can see the 
input bits change as I push the buttons on the front panel and step 
trough the program. The input clock is there as well (so I assume the 
M452 is working) but no data stream comes out of the module. Writing 
this I realize that I didn't check the device selector inputs. I'll do 
that tomorrow.

I know how to operate an oscilloscope and I have some experience with 
electronics but I'm not very good at reading logic and I only ever spent 
a couple days with this computer so I need some help here. Is there 
anything I have to look for especially?

Next I tried receiving characters. I hook my PC up to the W076X and 
start sending more or less random characters. They show up on the 
backplane side of the W076X module and on the input of the M706 but no 
data comes out either. The clock input is low all the time. Two of the 
select bits seem to be low all the time even if I execute the following 
program:

0000 6032 KCC
0001 6031 KSF
0002 5001 JMP 0001
0003 6036 KRB
0004 5001 JMP 0001

Actually the above program completely hangs the computer. I stays in 
"run" state and on address 0002 whatever key I press. That never occured 
before.

As you see I don't know too much about this computer. Am I using the 
right commands at all? I started reading the documentation and 
schematics (it is truly amazing how complete they are!) but I am not 
sure what to look for - what the signals on all the different 
"clear"-inputs of the M706/707 have to look like for example. Any hint 
is apprechiated!

Sebastian
PS: It's been a long day so don't mind me if I don't make too much sense...



More information about the cctech mailing list