Setting up a VAXstation

Tony Duell ard at p850ug1.demon.co.uk
Thu Oct 4 16:22:38 CDT 2007


> I'm not hardware-antipathic; I know which end of a soldering iron to
> hold [the cool one :)], and I've hacked together assorted electronics
> on occasion (a few of which I've even mentioned here).  However, most
> of my on-topic hardware, I have no particular interest in repairing
> below the board-swap level.
> 
> So, while I can't speak for anyone else in this regard, I can perhaps
> address your puzzlement as it applies to me.
> 
> Most of the hardware in question is SBus-era Suns.  I don't run it
> under emulation because an emulator, plus the hardware to run it on,
> would cost me a lot more than the Suns cost me (which latter figure is

RIght. I wish people would rememebr that when they try to convince me 
that the 'emulator is free'. Yes it is, but the hardware to run it on 
isn't and not everybody has a modern PC.

> usually $0 + shipping, and often the shipping is $0 because they're
> local).  Then, consider some additional points:
> 
> - Speed - emulators are usually slower than the real thing.  An
>    emulated setup capable of matching the real thing's speed will be
>    substantially more expensive.

I was under the impression that for many older machines (OK, not Sun 
workstations) the emulator running on a fast Pentium-x was considerably 
faster than th real thing. 

> 
> - Hardware compat - I have some oddball SBus cards.  I daresay
>    PCI-to-SBus, ISA-to-SBus, etc, bridges exist, but they will be
>    expensive, probably difficult to find, and may not even play nice
>    with the emulator.

Very good point. One reason I use some of the older machines is becuase 
of the wide range of interfaces available. HPIB is rare on PCs, very 
common on HP machines (:-)), very few PCs have an equivalent to the HP 
GPIO port, or the BBC Nicro user port, or ADC inputs, oe...

[...]

> Now, some of my stuff isn't SBus-era Suns.  Much of *that* stuff I *do*
> want to be able to repair down to the chip level - for example, I have
> some hp300 hardware with, I suspect, a blown HP-IB driver (last time I

I can't rememebr if schematics, etc, for thsoe are available. I assume 
you've poked about on http://www.hpmuseum.net.

> tried to use it I was seeing what looked like a stuck-at fault).  When
> I get the round tuits together, I'm going to see if I can confirm/deny
> my suspicion, and (if confirmed) pull a compatible driver chip from
> something else and do a swap.  Perhaps someday I'll be applying the

Of course damaged buffers driving external connectors are quite common. 
In older machines HP tended to use standard buffer chips to drive the 
HPIB connecotr (things like MC3448, SN75160/75161/75162). They did make 
their own custom buffer chip in a 40 pin DIL package (I forget the 
number, I can find it, and the pinouts, if you suspect you have it) that 
handles all the data and handshake lines (It is just a buffer, it doesn't 
do the handshake state machine functions), and which turns up in things 
like the 82169, 9122, etc.

> same philosophy to (say) the SPARCstation 20, and, if that happens,
> I'll probably then be glad I'm not chucking "dead" hardware....

Oh, indeed. If you don't have the skill or knowledge to repair it now, 
keep it for when you do (or give it to someone who does).

-tony



More information about the cctech mailing list