Altair 8800 Help (Another Follow-Up)

Rick Bensene rickb at bensene.com
Fri Oct 26 12:33:25 CDT 2007


An update on the Altair:

Rather than try to debug the problem with the ROM board, I just moved
the boot PROM to the lowest address socket, leaving the board select
address at 0xF400, and wrote a tiny program to copy the correct part of
the PROM into RAM at 0x4C00, as the beginning code in the boot PROM
does.  Put an infinite loop at the end of the little copier so I could
check on the copy.

First time around, the copy wasn't working.  Diagnosed to be a problem
on one of the 8K RAM boards.  Removed that board for now, and
reconfigured the two remaining 8K RAM boards so there was no gap in the
address space, resulting in 32K in the machine.

Tried again, and now I could see the boot code properly copied into
0x4C00.  

Next, I did some tinkering, and figured out that the low port on the
2SIO board was configured at the correct default I/O address.  Tinkered
with some RS232 cables I had, along with null modem/gender benders to
get a cable that resulted in garbage being displayed on the Televideo
912C terminal that came with the system when the CPU was powered on.
Then wrote some little tests to make sure I could send and receive
characters from the terminal, which worked just fine.

So, I re-entered the little "copy" routine, ran it, then halted the
machine from the infinite loop at the end of the copy code, reset the
CPU, set the address switches to 0x4C00, put the Altair Disk Extended
BASIC disk into the floppy drive, held my breath, and flicked "RUN".
The drive immediately loaded the head at Track 0, lights on the front
panel were blinking like crazy, then the drive advanced the head to
track 1, and then track 2, then suddenly, on the terminal, I see "MEMORY
SIZE?"!!!  

I ran through the initial dialog, and was able to MOUNT disk 0, then do
a RUN"PIP", and see the directory of the disk.  Since this was an
original disk, I didn't attempt to write anything to it.  The only
things on the disk are "PIP" and "STRTREK".  Can't run STRTREK because
the machine doesn't have enough RAM for it.  With Disk Extended BASIC
loaded, the machine reports 3072 bytes free after the initial dialog,
where I told the system to allow up to 3 open files at once, and 2
random files at once.  I'm sure that if I set it to 1 and 0, there'd be
considerably more space left for user programs, but probably still not
enough for STRTREK.  I need to figure out what is up with the sick 8K
RAM board, so I can get the machine back to 40K.

While rummaging through the stuff in the boxes of stuff I got with the
machine, I found a couple more interesting things.  A spare 2SIO board,
2 original MITS 4K RAM boards (I think these were the very trouble-prone
first generation dynamic RAM boards, which is why they probably aren't
used), and a bare board made by "wmc Inc." entitled "MEM-1", revision C,
with a date of 1977.  This appears to be a Wameco 8K Static RAM board
that uses 2101A RAMs.
No wonder it has four places for 7805 Voltage Regulators with heat
sinks.  I found an assembly guide on the Web, may go ahead and build it
out.  I've got a good stash of 2102's, and the rest of the support logic
I probably have in my cache of old TTL chips.

The unpopulated Ithaca Audio board is an IA-1010, and looking around on
the web, it's a Z80 CPU board for the S-100 bus.  It is a very
nicely-made board, with full solder mask, and nice silkscreen.  So far,
haven't been able to find any assembly information for this board,
though it'd be interesting to build out and try.  I think I've got a
couple of Z80 chips around here, and probably enough parts to populate
it.

Things to do:

1) Figure out the problem with the ROM board
2) Try to fix the busted 8K RAM board
3) Build a cable to connect the floppy DRIVE 0 chassis to the DRIVE 1
chassis (so I can run both drives)
4) Start exploring all of the other floppies that came with the system
5) Check out the TI 810 printer and see if I can get it hooked up to the
system and working
6) Do some tinkering with the TV Typewriter, and see if it's functional,
though with all the mods, it'll be a bit of a challenge.

So far, I'm pretty encouraged with how things are going.  None of the
problems found thus far are showstoppers .

Comments & suggestions are welcomed, either (if appropriate) by posting
here, or sending me Email off-list.

Rick Bensene
The Old Calculator Museum
http://oldcalculatormuseum.com




More information about the cctech mailing list