anyone do vaxstation repairs?

Dave Dunfield dave06a at dunfield.com
Sun Feb 24 21:34:56 CST 2008


> 
> I'll check out SIMH.
> actually my Linux system claims it can read a vms drive. that'd be rather interesting.

I find SIMH to be an invaluable tool, especially under Linix. For the SCSI VAXen, if you
have (or put) a SCSI card in your Linux box, you can point the SIMH definition at the
raw device and actually mount the physical drive under the simulator. You can even boot
from it if you have virtual hardware defined which is close enough to what is expected.

Or - you can DD the drive into a big file and point SIMH at that - it's much easier to
recopy a file than to rewrite a drive - so when I want to screw around with "dangerous"
things, I tend to do it on a file copy of the drive under SIMH.

Finally, once you get your drive into an image, you can burn it to a CD and mount it
(or even boot it if it's a stand-alone-backup disk) from a CD drive on you real VAX.
(I happen to do this by transfering the disk image to a windows box where I use NERO
to burn it - Say NO when it asks if you want to "fix" the identifier bytes in the ISO
which it doesn't think look right!  Using SIMH, you can make a 650M disk, copy all the
stuff you want from your real drives, and then turn that image to a CD which makes for
an easy way to make VAX readable backup disks.



> as for the password, yes I know the routine, except the stubborn system doesnt want to accept it. I
> follow all the steps, run authorize, change the password. but when i try to login with it, it says
> its not correct.

Very strange - I've had to reset the passwords on a couple of my VMS system when I got them,
and it's always worked for me.

> 2 possibilities, either the license is no good (its a new one),

If you are configured for a serial console as OPA0:, you can log in as SYSTEM without
having to have a valid VMS license on the system.

>they put the units=0 which bothers

I have several VMS licenses which have units=0 and they all work fine. I did read somewhere
that it's supposed to have UNITS= "at least 100", but I have no idea what this is for/means.
The only VMS license I have which has a non-zero UNITS is a VAXstation only (ACTIVITY=D)
which has UNITS=200 ...

> me. or the pwdchange=pre-expired is the culprit.

Doesn't pre-expired just mean that it will force you to change it the next time
you log on. Ie, it's already expired rather than having to wait for the 30 days
or whatever the expiry time is set to on your system. I don't think it makes the
password invalid, just marks it as expired so that you will have to change it.

Dave

--
dave06a (at)    Dave Dunfield
dunfield (dot)  Firmware development services & tools: www.dunfield.com
com             Collector of vintage computing equipment:
                http://www.classiccmp.org/dunfield/index.html



More information about the cctech mailing list