PDP-11 bootup

John Floren slawmaster at gmail.com
Thu Mar 26 00:35:03 CDT 2009


On Wed, Mar 25, 2009 at 11:31 PM, Jerome H. Fine <jhfinedp3k at compsys.to> wrote:
>>John Floren wrote:
>
>>> On Wed, Mar 25, 2009 at 11:06 PM, Zane H. Healy <healyzh at aracnet.com>
>>> wrote:
>>
>>>> On Wed, 25 Mar 2009, John Floren wrote:
>>>
>>>> I just brought home my spiffy new MicroPDP-11, hooked it up to my
>>>> laptop (couldn't find cables to go to any real terminals) and tried
>>>> booting. Right now, all I see at power-on is:
>>>> 173000
>>>> @
>>>>
>>>> I can type things after the @, but it seems that pretty much any
>>>> keypress results in a '?' and a new prompt.
>>>>
>>>> I'm a total PDP-11 newb, but the users manual implied that I should be
>>>> seeing some sort of post-ish procedure similar to what you get on a
>>>> VAX. Any ideas?
>>>>
>>>
>>> What boards are in the system?  Is the CPU dual or quad height?  What
>>> board
>>> is the terminal hooked to?  IIRC, this indicates you're lacking a
>>> bootstrap.
>>> If we know what boards, and drives you have we can probably better advise
>>> you.
>>>
>>> Zane
>>>
>> This is on a KDJ11-A (dual height). I've just been reading the manual
>> and yes, as Josh notes, it seems that I'm in the ODT prompt. Do I just
>> want to try "P" and see what happens?
>>
>> Right now I have the drives disconnected, but it has the standard dual
>> 5.25" floppy drives and Maxtor XT-2190 (190 MB) drive in it. At the
>> moment, I have the power supply to the drives disconnected because I
>> wanted to make sure I could get to a boot prompt sort of thing without
>> spinning up and spinning down the hard drive all the time--I also
>> wanted to avoid having it start booting RT-11 while I'm not watching
>> the console.
>>
>> Currently the card stack looks like:
>>
>> [     dual-height KDJ11-A      ] [empty] [empty]
>> [ board connected to serial lines] [empty] [empty]
>> [ Three connected boards that I believe are     ]
>> [  extra hardware installed by the lab              ]
>> [                                                                 ]
>> [   another board
>>
> Jerome Fine replies:
>
> My best guess is that you have a BA23 box since you seem to be describing
> having two 5 1/4" drives included in your configuration.
>
> Since RT-11 is quite happy to boot with the drives in WRITE  PROTECT,
> I suggest that you attempt to figure out the "sort of" front panel which
> allows
> that to be done for the RD54 (Maxtor XT-2190).  If you have a floppy as
> well, place a WRITE  PROTECT tab on it.
>
> If you can also provide the names of the boards, that would be more helpful.
> With a KDJ11-A (dual) CPU which does not have an boot ROMs, you may
> have a third party controller for the drives with a boot ROM.  Otherwise, if
> you have an RQDX3 (M7555 dual board - required for an RD54) which
> does not have a boot ROM and there is no other board with a boot ROM,
> you will have to enter the boot program via ODT.  Since this takes only
> about
> 5 minutes to do, it is not an impossible situation.
>
> Any other question?
>
> Jerome Fine
>


Here is a complete list of the boards in my system, as removed from
top to bottom (this was a rack mount unit)
1x M8192
1x M7195
1x mysterious quad-height board from DEC; I can only find labels
saying "PC304135-I4", "0202", and "Rear PSW1-0"
2x Matrox QRGB-G-64/4 boards
1x Matrox QVAF-512/8A (or QVAF-5/2/8A, hard to read)
1x Dataram 40903 (memory? It's got tons of little ICs)
1x M7941
1x M7555


Here are all the boards I have that were *not* installed:
1x M9400
2x M7946
1x TI GPIB11V-1
5x M8045
1x Data Systems Design A44324
2x M8043
1x M8192
1x DT 2766
1x M7195
1x M8059
1x M7270
1x 3com board, all I can find is "QE serial 0223-01". It's dual-height
1x Data Systems Design 804140
1x M9400
4x M8013
1x M7856
2x Matrox QRGB-G-64/4

Hope this helps


John Floren
-- 
"I've tried programming Ruby on Rails, following TechCrunch in my RSS
reader, and drinking absinthe. It doesn't work. I'm going back to C,
Hunter S. Thompson, and cheap whiskey." -- Ted Dziuba




More information about the cctech mailing list