Xerox 820 system disks in Teledisk format?

Steven Hirsch snhirsch at gmail.com
Wed May 6 17:58:46 CDT 2009


On Wed, 6 May 2009, Dave Dunfield wrote:

> I'm not sure what you mean by "mapped as drive D:" - Is this with the DOS
> driver? Unit 2 (in 0..3) would be C: for ImageDisk (Like Chuck suggested
> earlier, ImageDisk's A-D represents units 0-3 on the primary floppy
> controller - NOT any sort of OS mapping). I'd recommend NOT using any extra
> drivers with ImageDisk (it talks directly to the hardware, and external
> drivers can interfere with that if they are triggered on an interrupt).

Dave's message gave me enough hints to (finally) get ImageDisk running 
with the Compaticard IV:

1. Disable on-board FDC in BIOS
2. Jumper CC4 to port address 370h
3. Disable CC4 ROM
4. Remove CC4.SYS from CONFIG.SYS
5. Reference the 8" drives (units 2 and 3 on the controller) as 'C:'
    and 'D:', even though C: is my hard disk and D: is the CD-ROM
    drive (as far as the BIOS is concerned anyway).

I had tried various subsets, but never all those things together.  In 
particular (5) is a bit unintuitive.  It's more than a little scary to 
invoke write or format operations with drive C: specified to ImageDisk.

IMHO, it would be much clearer to reference them by unit number.  But 
maybe that's just me...

The testfdc program still fails everything when targeting the 8" drives 
and I believe I know why.  From the sound of things, it tries to do 
everything on the last tracks (lowest linear velocity) and has it in it's 
head that there are 80 available.  I can hear it slapping against the stop 
on the 8" drives - at least that's what it sounds like.  Be that as it 
may, all tests fail with "Data not found".

Once I began to suspect this was a red-herring, I tried some real read and 
write operations.  Lo and behold: Everything is just fine!  I'm able to 
create bootable diskettes from the .imd files.

Life is Good.  I hope this helps others in the same boat as me 
hardware-wise.

Steve



-- 



More information about the cctech mailing list