i8355 from SDK-85 flakey

Chris Elmquist chrise at pobox.com
Mon Apr 26 06:45:11 CDT 2010


Thanks Dave!  I appreciate the effort very much.

I'll check the datasheets too but there may be one pin that's different
on the 8355 from the 8755.   On the SDK-85 board, there is a strapping
option to choose which device you are using and it messes with a +5 or
GND pull on one pin.   Pin 5 seems vaguely familiar but I need to confirm.

So, there may be at least one difference between the two devices required
before you can fool the UniSite into reading the 8355.

Chris

On Monday (04/26/2010 at 01:08AM -0400), Dave McGuire wrote:
> On Apr 24, 2010, at 8:22 PM, Chris Elmquist wrote:
>> I'm guessing that's probably unobtainium so, failing that, wondering if
>> there's a .HEX of the ROM image floating around so that I don't have to
>> type it all in.   If I have the bits, I can burn a 8755 that drops  
>> into
>> the same location.
>
>   Hmm, weird.  I tried to read the ROM contents from the 8355 in my  
> SDK-85, but my Data I/O UniSite, when configured for an 8755A, complains 
> of a device insertion error.  Everything is set up properly, and the 
> UniSite is fine, I use it all the time.  I've checked the databooks and 
> the 8355 and the 8755 should be completely interchangeable with the 
> obvious exception of programmability.
>
>   I've not fired up this SDK-85 for a few years, but it worked fine  
> then.  I have to go to sleep soon, and I'll be out for much of the day 
> tomorrow, but perhaps tomorrow night I'll be able to wire it up to a 
> power supply and see if it still runs.
>
>             -Dave
>
> -- 
> Dave McGuire
> Port Charlotte, FL
>

-- 
Chris Elmquist




More information about the cctech mailing list