PDP-11/23 Debugging

Ben Sinclair bensinc at gmail.com
Sun Nov 16 21:44:43 CST 2014

Well, I just discovered something interesting... What exactly does the aux
switch on the front panel control? I assumed it was power to the AC plug on
the back of the machine, but it must do something else. With aux in the
down position, it again boots to XXDP! If I flip it up and restart, it
drops back to ODT after trying to boot XXDP from the TU58.

>From the documentation, I don't see that it does anything other than
control that AC plug.

I'm not sure what to make of it! If I'm having some sort of power issue, I
don't see it on the BDV11 test points. They read 4.96 and 12.00, which I
think is correct.


On Sun, Nov 16, 2014 at 9:16 PM, Ben Sinclair <bensinc at gmail.com> wrote:

> Sorry for all of the replies to myself! I just tried booting with halt on,
> so it didn't try and boot from the TU58 emulator, and I entered the memory
> address program from http://www.psych.usyd.edu.au/pdp-11/hints.html.
> When I run the program, it halts at 000014. According to that site, the
> error address should be in R1, which reads as 004330. I did try and write
> to that location, and it reads back fine.
> I'm confused though, because it halts at 000014, but that program doesn't
> have an instruction at 000014. That may just be me not understanding how it
> works, but I would have thought it would halt on some location that
> actually had an instruction.
> I'm afraid I've messed this thing all up! I had it working better before I
> started messing with it, but I guess that's the fun part!
> On Sun, Nov 16, 2014 at 9:04 PM, Ben Sinclair <bensinc at gmail.com> wrote:
>> I just tried swapping the chips from my "new" M8186 to the old, and have
>> the same result, by the way!
>> On Sun, Nov 16, 2014 at 8:54 PM, Ben Sinclair <bensinc at gmail.com> wrote:
>>> I happened to already have a manual wire wrap tool, and it actually
>>> works pretty well! I was able to wire wrap the jumpers on my serial card
>>> and they seem pretty secure.
>>> However, I'm having other strange problems now. I'm not sure what I did,
>>> but at the moment I can't seem to boot into XXDP as I could before. It
>>> halts back to ODT at 00104, but I know from past runs that the restart
>>> address is 152010. If I do a 152010g, it does run XXDP and seems to work.
>>> I was messing with the halt option on my DLV11, but I currently have it
>>> set to go to ODT on break, which is what it's always been set to. I'm
>>> actually not sure what the common setting for that would be. It's either
>>> break, boot, or do nothing. It was on break earlier, and worked, so I think
>>> something else may be wrong.
>>> I'm currently only running with the CPU, memory, and serial boards
>>> installed.
>>> I did try what you suggested while trying to fix the initial problem. I
>>> reseated the boards and made sure the jumpers were secure, and reseated the
>>> two chips on the CPU board.
>>> I did receive my "new" M8186 from eBay, but it's missing all of the
>>> jumpers, and there is a strange modification... On my original M8186, there
>>> is a capacitor on the left, after the first row of chips, when looking at
>>> it from the tab side. The "new" one has that capacitor replaced with a
>>> piece of perfboard with two smaller capacitors, and a two pin connector. I
>>> have no idea what that might be, but I don't think I should try this board
>>> until I figure it out.
>>> One thing I was thinking of trying was moving the socketed chips from
>>> the new board to the old... I don't have any other great ideas right now
>>> though!
>>> On Tue, Nov 11, 2014 at 6:11 AM, Noel Chiappa <jnc at mercury.lcs.mit.edu>
>>> wrote:
>>>>     > From: Ben Sinclair
>>>>     > what is the best way to connect the wire-wrap jumpers? I've never
>>>>     > actually wire wrapped anything, but is that what I should do?
>>>> Well, I use wire-wrap, but anything that makes a good connection and
>>>> doesn't
>>>> get in the way (of other cards, etc) is fine, really. Don't feel you
>>>> have to
>>>> use wire-wrap, or anything.
>>>> If you want to wire-wrap, there are two ways to go. They used to make
>>>> manual
>>>> tools for wrapping the wire, but I've never used those; I learned with
>>>> a gun.
>>>> Those are available on eBay now for relatively cheap, since wire-wrap
>>>> is now
>>>> more or less obsolete (if you're slightly patient - I paid $25 for a kit
>>>> containing two guns, a bunch of different tips for different gauge wire,
>>>> several packages of pre-stripped wires, several of the strippers that
>>>> cut the
>>>> wire and strip the right amount, and some un-wrap tools - a great deal
>>>> :-);
>>>> that's the way I'd go.
>>>> They are pretty easy to use; the only real trick is to learn how to
>>>> apply just
>>>> the right amount of up-down force while doing the wrap. Too much up,
>>>> and you
>>>> tend to pull the gun up as it wraps, and you don't get a nice tight
>>>> wrap.  Too
>>>> much down, and you get an ugly ball at the bottom of the post as the
>>>> wrap
>>>> winds around itself. The trick is to try and hold the gun neutrally
>>>> weighted,
>>>> and as it wraps let it push _itself_ up the pin, producing a nice tight
>>>> wrap.
>>>> And of course you can do test wraps, and undo them if they come out
>>>> looking
>>>> bad. It doesn't take long to get reasonably good with it.
>>>>         Noel
>>> --
>>> Ben Sinclair
>>> ben at bensinclair.com
>> --
>> Ben Sinclair
>> ben at bensinclair.com
> --
> Ben Sinclair
> ben at bensinclair.com

Ben Sinclair
ben at bensinclair.com

More information about the cctech mailing list