Deciphering PDP-11/05 ZQKC (Instruction Exerciser) MAINDEC failures...

Josh Dersch derschjo at
Sun Nov 8 11:50:06 CST 2015

Hi all -

As noted in a mail last week, I now have my PDP-11/05 running with working
core (8KW).  I had some time last night to try loading in some "real"
software, and I started with the PDP-11 paper-tape BASIC, which I've
successfully loaded into memory (in theory).  At this point, it became
clear that there's still an issue or two to iron out in the CPU; BASIC
behaves extremely erratically, spewing random error messages, listing
garbage, and corrupting itself and crashing pretty quickly.

I'd run the memory exerciser MAINDECs previously (and I ran them again for
good measure) and there are no obvious issues with the memory.  The system
exerciser diagnostic (ZQKB) passes, but the "11 family instruction
exerciser" (ZQKC) fails after a minute or so at PC=016014.

I have the listing for the diagnostic (though I'm not precisely sure
whether it's exactly the same revision) from here:

The doc is pretty grainy but the code at 016012 doesn't actually seem to
match what I've got in memory (I disabled relocation in the test just to be
sure things didn't get moved around) and there's no failure check at that
particular point in memory either.

I've tried the paper-tape images from Bitsavers as well as the ones on the
XXDP RL02 images floating around out there and they all yield the same
results; I suppose it's possible the CPU is failing in such a way as to
make the test reporting incorrect but it seems more likely that (a) I have
an outdated listing or (b) I'm misinterpreting the results somehow.

Anyone have any experience with this particular diagnostic?


More information about the cctech mailing list