Deciphering PDP-11/05 ZQKC (Instruction Exerciser) MAINDEC failures...

Jay Jaeger cube1 at
Mon Nov 9 14:37:16 CST 2015

On 11/8/2015 11:50 AM, Josh Dersch wrote:
> Hi all -
> As noted in a mail last week, I now have my PDP-11/05 running with working
> core (8KW).  I had some time last night to try loading in some "real"
> software, and I started with the PDP-11 paper-tape BASIC, which I've
> successfully loaded into memory (in theory).  At this point, it became
> clear that there's still an issue or two to iron out in the CPU; BASIC
> behaves extremely erratically, spewing random error messages, listing
> garbage, and corrupting itself and crashing pretty quickly.
> I'd run the memory exerciser MAINDECs previously (and I ran them again for
> good measure) and there are no obvious issues with the memory.  The system
> exerciser diagnostic (ZQKB) passes, but the "11 family instruction
> exerciser" (ZQKC) fails after a minute or so at PC=016014.
> I have the listing for the diagnostic (though I'm not precisely sure
> whether it's exactly the same revision) from here:

So, this one would likely be named something like DZQKCC.BIC (or .BIN)
on disk.  My guess is that yours is a different file name in the last
two characters before the period.

The paper tape image I found on bitsavers is two revs up from that -
DZQKCE.  I didn't take the time to start up a disk image and look at it.

> The doc is pretty grainy but the code at 016012 doesn't actually seem to
> match what I've got in memory (I disabled relocation in the test just to be
> sure things didn't get moved around) and there's no failure check at that
> particular point in memory either.
> I've tried the paper-tape images from Bitsavers as well as the ones on the
> XXDP RL02 images floating around out there and they all yield the same
> results; I suppose it's possible the CPU is failing in such a way as to
> make the test reporting incorrect but it seems more likely that (a) I have
> an outdated listing or (b) I'm misinterpreting the results somehow.
> Anyone have any experience with this particular diagnostic?
> Thanks,
> Josh

The version can normally be identified either by the file name or on the
paper tape if you are using a real paper tape.  My guess is that the
version you are running does not match the PDF.

Some of us also have diagnostic listings of various versions, and have
some of them on Microfiche.  Unfortunately, I do not seem to have a
listing for DZQKC (any revision).  [It isn't missing - it isn't even
listed in the fiche index.  :( ]

HOWEVER, I *DO* have a *paper* listing of revision E (among others).
The code starting at 16002 reads

016002  105737 177564      TSTB @#TPS
016006  100375             BPL  .-4
016010  006237 177564      TSTB @#TPS
016014  000001             WAIT          ; WAIT FOR FIRST INTERRUPT

The routine starts at 015734 and the comment is ";CHECK TTY INTERRUPT"

AND, the paper copy has a red stamp indicating that a change may be
required for it to operation.

  LOC  FROM     TO
 2266   200     340
14146   200     340
16164  5227    4737
16166     0     160

 160      -     5227
 162      -        0
 164      -     1375
 166      -      207

So, please provide either the complete file name you loaded (if you are
loading from RX, hard disk, DECTape, etc., or the complete information
on the paper tape and we should at least be able to help you figure out
if they match, or not, and whether or not someone has a listing that
matches and can tell you what the error might mean, and perhaps provide
a scan to you (and bitsavers).


More information about the cctech mailing list