RQDX3 as secondary MSCP controller

Mark G Thomas Mark at Misty.com
Sun Aug 28 17:19:25 CDT 2016


Last year I rescued a dual-wide 8-position q-bus backplane. I added the 
wire wrap to convert it from 18 to 22-bit, and now can boot BSD2.11 from 
CMD/CQD SCSI controller and CF card at DU0, via an AztecMonster 
CF-SCSI adapter. If I remove the SCSI controller, I can boot XXDP 
from an RQDX3 connected floppy drive at DU0.  My CPU is an M8192 from the 
scrap-card guy on e-bay, and I'm using an M7195 SLU/ROM card for 
console. It's got 23-14534/23-146E4 ROMs. I'm using a 2MW Clearpoint RAM card. 
I'm fabricating a cool desktop flexiglass case, so I can put the tiny-pdp11/73
on the desk at work.

The difficulty I am having is I would like to configure the system with
both MSCP controller cards installed, so I can boot from either SCSI or 
floppy, preferably with the SCSI still starting at DU0 so my BSD2.11 CFs 
remain portable to my other system.

I changed the W1-W11 jumpers on the RQDX3 for 17760334 secondary MSCP address.
And, I installed W12 to start at MSCP unit number 4. I used the menu on
the SCSI controller to set it for DU0-DU3-only device mappings (SCSI ID 0-3). 
My understanding is each controller needs the different CSR, and non-overlapping
MSCP unit numbers. I confirmed I (finally) got the RQDX3 address jumpers 
because the bootrom memory map now displays 17760334-17760336 as in use, as
well as 17772150-17772152 for the SCSI controller.

I was expecting that I'd now be able to boot from the floppy at DU4
(BOOT> DU 4), but after a long pause, I get ?BOOTROM-F- DU 4 device error.
I also tried "BOOT> 17760334 DU 4", but still no joy.

Another oddness I noted was that with my original RQDX3 config, if I 
plug the M7516 ethernet card in, that breaks booting from floppy.

Are there some other jumper changes I need to make on the RQDX3? 

Does anyone have any other suggestions about what I might be doing wrong?


Mark G. Thomas (Mark at Misty.com), KC3DRE

More information about the cctech mailing list