PDP-11/34a hung bus problem.

E. Groenenberg ed at groenenberg.net
Sun May 15 01:33:02 CDT 2016

On Sun, May 15, 2016 01:17, Don North wrote:
> On 5/14/2016 2:41 PM, Noel Chiappa wrote:
>>      > From Ed Groenenberg
>>      > - insert both CPU cards, KY11-LB card & bootstrap card, 5 full
>> grant
>>      > cards, DL11-W  and bus terminator card.
>>      > ...
>>      > - cntrl + boot shows register dump at printer.
>>      > ...
>>      > All looks ok
>> I'm surprised the bootstrap ran OK with no memory at all in the machine.
>> I
>> vaguely STR that I had a machine that would not work like that, but
>> maybe I'm
>> wrong. (DEC bootstaps tend to do things like set the NXM vector, in low
>> memory, so they can size memory; and when it gets the NXM (since there
>> is no
>> memory) from trying to touch the NXM vector, and tries to push the old
>> PS and
>> PC to service _that_, and gets _another_ NXM, that 'double bus fault'
>> often
>> causes many -11 processors to do a cheap suit)
> If the bootstrap card is an M9312 with the standard console PROM, it does
> require any
> memory to be present/accessible to get to the ODT prompt that prints out
> the
> registers and
> waits for a command. Only until you execute a device bootstrap command
> with
> 'diagnostics
> enabled' (the default) does the memory sizing/test/diagnostic code get
> exectuted.
> Listing:  http://ak6dn.dyndns.org/PDP-11/M9312/23-248F1/23-248F1.lst
> So the system working to this level with no memory present is normal.
>>      > power down machine, add memory (M7981, 128KW)
>> What's an M7981? Did you mean an M7891 MS11-L?
>>      > - power up machine -> run light is on, does not get cleared by
>>      > cntrl + halt.
>> This is where a UA11 would really help. I had similar issues with an
>> -11/04,
>> and the UA11 was a huge help in figuring out what's going on. One glance
>> and
>> you can see if a bus line is wedged, or something.
> Agreed, a bus probe would really be helpful in further debug. Given that
> the
> system does not
> even get back to the ODT prompt (which would not yet access memory)
> indicates
> that logic
> on the memory card is hanging the bus. Could be a bad bus driver interface
> chip
> (8641, etc).

I'll hook up the bus analyzer and see it there is something to see.

>>      > - power down & replace memory with grand card -> run light is
>> off.
>> Well, that's good sign - the memory card didn't fry anything, at
>> least...
>>      > - tried a 2nd memory card (M8722, 128KW)
>> Ooops. The MS11-M needs +/-12V, which is _not_ standard in most
>> machines/backplanes). The EUB in the 11/24 and 11/44 (which this card is
>> intended for) does have it. The really bad part is that those same pins
>> usually carry +/-15V in most MUD backplanes. So hopefully you didn't fry
>> it.
>> It does have standard UNIBUS as well as EUB, but there's a jumper, IIRC.
> Bad idea to put this card in an 11/34. As indicated the +12V VDD rail on
> the
> memory chips
> is wired directly to the UNIBUS +15V line in the 11/34 (which can be set
> to +12V
> in the 11/44).
> So you placed +15V (or more likely up to +15.5V or so) onto the memory
> chip VDD
> lines.
> Some 16K chips had a 15V max spec on this pin, others only 13.2V. So it is
> possible you
> toasted so memory chips, or not, depending on manufacturer and their
> sensitivity
> to OV.

I'll label the card as 'possible not working' for a test later in a proper

> In any event, DO NOT use this card again in the 11/34. It is not
> compatible with
> the backplane.
>>      > So what could be the problem here? The bus works without the
>> memory
>> Two possibilities off the top of my head. i) The first memory card is
>> bad (or
>> configured incorrectly), or.. ii) The M7891 uses +/-15V as well as +5V?
>> So
>> maybe one of the other voltages is not so good? But you said the console
>> worked, and I think that uses other voltages (at least, in EIA mode -
>> not
>> sure about 20mA, I never touch the stuff).
>> 	Noel

Ik email, dus ik besta.
BTC : 1J5fajt8ptyZ2V1YURj3YJZhe5j3fJVSHN

More information about the cctech mailing list