Recovering 4mm tar tapes

Steven M Jones classiccmp at
Mon Sep 12 19:50:17 CDT 2016

On 09/12/16 16:35, Douglas Taylor wrote:
> I tried using different blocksizes with no luck.  Debian does have the
> mt command and I was able to use it to get the tape status, rewind and
> was able to have it move the tape forward a number of records (not sure
> what a record is)
> #mt -f /dev/st0 fsr 10
> worked. 

But as soon as it skipped anything, it would have rewound to the
beginning of the tape...

Rather than skipping records, I'd be curious about skipping the first
"file" in case you have an EOF mark at the start of the tape. You'd do
this with something like "mt -f /dev/nrst0 fsf 1"

The previous suggestion of using dd(1) is a good one, maybe you tried
the following and maybe not. Use the "mt rewind" command to make sure
you're at the beginning of the tape, then use dd with the "no rewind"
device, e.g. /dev/nrst0 or nst0. Hit it a couple times just in case
there were some bad writes at the start of the tape.

% mt -f /dev/st0 rewind
% dd if=/dev/nrst0 of=file-1.bin
% dd if=/dev/nrst0 of=file-2.bin
% dd if=/dev/nrst0 of=file-3.bin

You may just get zero-length files. Or, maybe you'll get past some
damage and get some of your data. Worth a shot, provided the tape isn't
shedding oxide...

> I guess the cartridge is bad.

Possible. It also sounded like your problem tape might be DDS-1, while
your other tape might have been a later, higher capacity. Might that be
a problem for the drive you have? I haven't tried different density 4mm
tapes in drives in ages...


More information about the cctech mailing list