pdp-8/e restoration.

Rod Smallwood rodsmallwood52 at btinternet.com
Mon Aug 7 12:37:18 CDT 2017



On 07/08/2017 17:05, Philipp Hachtmann via cctalk wrote:
> On 04.08.2017 09:24, Rod Smallwood via cctalk wrote:
>> Hi List
> Hi Rod!
>
>>           I looks like I have at last got a KK8-E CPU set to continue 
>> getting my 8/e back running again.
> It looks that you have one more set stored in my facility in Hannover!!!
> I became feeling more and more bad about that. Then I forgot it again. 
> Then I felt even more bad by not remembering WHOSE boards those are 
> (because there is no "Rod Smallwood" written nowhere on the packet).
> Now I have connected that again....!
>
>> The system has a working rebuilt PSU with all of the caps reformed or 
>> replaced. Voltages are good.
> Wow, I never did that. I always made a smoke test.
>
>> There's 16k of core at the back with a terminator at the end.
> Not bad.
>
>> Power up and all the lamps come on either bright or dim (off) except 
>> the RUN light.
> Sounds not so wrong.
>
>> 2. Are there any tests like resistance I can do on the CPU board set 
>> before inserting them in the correct front slots?
> There are no "correct" slots. Not for *any* of the boards. You can mix 
> it up completely. Even the front panel could be omitted, doubled, or 
> put into an expansion box.
> BUT.. There actually IS a DEC recommended order, yes... And having the 
> terminator board somehow at the end of the Omnibus seems to be a good 
> idea.
>
>> 3. In the event the CPU set does not even do a simple write to and 
>> read from memory. Where do I start to look?
> At the schematics? Front panel (!), timing generator, major state 
> registers.
>
> The DEC stuff was designed quite wrong-insertion resistant. But:
> There is just one MAJOR fault you HAVE TO AVOID: NEVER NEVER NEVER 
> plug in the middle board of an RK8E controller upside down!!
>
> I did it. Once. It leads to impressive fireworks on many boards.
>
> Regards
> Philipp
>
Its now running just fine.
Count test runs.
The second set of 4k core is in and checks out.
Async. board has just gone in and is running.
I'm getting output RS232 on my BOB  when the print test is toggled in 
and run.
So to-morrow connect up a terminal that will do 110 baud and try an echo 
test.

Next part is interesting. There should be a way to fake a reader / punch 
and feed in tape images.

Rod

-- 
Wanted one pdp-8/i rocker switch leaver to copy.



More information about the cctech mailing list