TC11 / TU56 repair - cannot get ZTCB to run.

Mattis Lind mattislind at gmail.com
Sat Jun 10 11:09:10 CDT 2017


I have been working on getting a TC11 with a TU56 running. It is connected
to a PDP-11/05.

First it failed on ZTCA diagnostic but it was quite easy to track down a
failing N8281 on M795 board which made bit 9 of the Current Address
register to be stuck high.

Then I tried ZTCBE0. Unfortunately I din't find the matching listing.

When trying to run this one it constantly says:

"FATAL ERROR TRAP TO LOCATION 4 FROM LOC012660
 (?BAD CPU?) ATTEMPTING RO RESTART PROGR"

But as far as I can tell the CPU is good. I ran every possible CPU
diagnostics without any problem. I also ran five different memory tests -
no problems.

Anyone has a clue what is wrong?

12660 is a mov (r1)+, (r2)+ so it might be addressing outside memory. The
listing states that it needs 8k core and I do have 8k good core in the
machine.

Then I ran ZTCC through ZTCE which all works fine. I do get occasional
error but I think it has to do with the tape which was not newly formatted.

Finally I tried to run a DECtape formatter. Again I had problems with
listing mismatching the binary.

The program halted on me at locations which were not the same as in the
listing. I pressed continue and it did. I looked at what it did: The first
pass was doing WRTM on the entire tape. Then it halted and I pressed CONT.
Now it did WALL, followed by RALL and finally WDATA followed by a HALT.

Pressing another CONT just repeated the procedure once more. It looks like
the tape was correctly formatted but I am not 100% sure.

Does anyone has more info on the DECtape formatter program? Possibly a
listing and a binary that matches?

/Mattis


More information about the cctech mailing list