iMac ethernet connection quit - help?

Tapley, Mark mtapley at
Tue Jun 27 09:56:28 CDT 2017

On Jun 26, 2017, at 4:33 PM, Wayne Sudol via cctech <cctech at> wrote:

> Mark,  try opening a terminal window.  ifconfig -a will show you all
> interfaces and their status. If en0: is down you can try ifconfig  en0: up

This made a tiny difference. …up changed the ifconfig report to (from memory):


(including RUNNING) while …down changed it to:


(no RUNNING flag).  However no ping, and the connect light on the hub still depended exclusively on manually setting rate to 10T/UTX (lit) or anything else (not lit).

> The man page from a terminal window will help with the options to the
> ifconfig command. I.E. man ifconfig

It did help, sort of. I kind of wish networking were less arcane, though I’m sure there are good reasons it’s the way it is.

> Here's an example from my mac.

the inet6 lines are not on the G4 ifconfig report - this seems good, since IPv6 is turned off.  Else it looks pretty similar if not identical. Also it looks I think identical to the ifconfig report from my G4, with the exception that the G4 has an en1: (corresponding to the wifi card, I think) section.

After some surfing, I also tried: ipconfig getifaddr en0 
That produced a message ending  '...failed, (os/kern) failure"

On Jun 26, 2017, at 10:01 AM, Liam Proven via cctalk <cctalk at> wrote:

> Is the firmware up to date?

I looked at system logs. There are version numbers there for a lot of things  but I forgot to write most of them down (and I’m back at the office and the machine is at home). The one I did preserve was:

Console log: 
Server 3f07 in bootstrap 1103 uid 0: "/usr/sbin/lookupd"[43]: exited abnormally: Hangup.

I’ll have another go tonight and will do some web-surfing for more clues today. Am I looking for anything specific?

> is running OS X, you can't update the firmware -- you need Classic
> MacOS 9 to do that. :-(

Also have not taken time to find OS9 boot CD. I’m hoping I can configure a USB drive as OS9 boot, move it to the PowerBookG4 to download firmware update, move back to G3, launch, update, then re-boot from internal hard drive. Is this feasible?

> Have you tried a different hub?


	I did, and this took some time. First test was unplug the ethernet cable from the G3 and plug it into G4, no other change. G4 ran internet normally, so I think hub, modem upstream, etc. are likely to be OK. I also tried cross-connecting G3 to G4, but no ping either way to the manually configured iP’s on both machines. I forgot to try AppleTalk networking while cross-connected, but I’m not sanguine about it working.

	Next test was remove Asante EtherHub 10T/8 and replace with 2Wire DSL cable-modem, intending to use its internal 4-port ethernet hub.  The cable from the wall to the Asante had been plugged into its unique crossover port (port 1 has a straight-through and a crossover, so  the Hub can be used to extend another hub conveniently without using a crossover cable). Therefore, when I plugged in the 2Wire, I changed to use a crossover cable from the wall to duplicate that effect. 

	Lots of blinking lights ensued. I’m theorizing the 2Wire and my AT&T Uverse cable modem were having a heated discussion about something, over either ethernet directly or possibly Wi-Fi then gated to ethernet. The G4, now plugged into the 2Wire, could eventually access the 2Wire configuration web-page but it was very slow and there were many dropped connections (according to TenFourFox, my web browser). I did finally successfully reset the 2Wire password, and used my Cellphone with ConnectBot to log into the G4 via: (wifi) ->  AT&T -> (ethernet? I think not wifi?) -> 2Wire -> (ethernet) -> G4. That also was very slow, but I think it showed most of the connections were live. 

	Testing the G3 showed the exact same behavior as before. The (rapidly blinking) connection light on the 2Wire hub was illuminated only when ethernet rate on the G3 was manually set to 10T/UTX. No pings in or out, even when both G4 and G3 were set to manual iP addresses and I pinged those addresses (and the addresses were in the range normally assigned by DHCP). The complaint was usually “no route to…” . Also no ping from the G3 to the LaserJet 4M+ on the same (2Wire) hub, although the LJ4M+ did respond to ping from the G4.

	At this point, a call of: “Dad, did you do something to the internet?” put a halt to further experimentation. “Um….” <disconnect, power off, etc.> “…um no, why? Maybe if you try again? :-)” 

	Only about 15 minutes later, after plugging the printer straight into the wall (cutting all hubs and the G3 out of the circuit and shutting off the 2Wire WiFi) did service go back to normal. See above about arcane networking….

	I’m reasonably convinced the hub, modem, cabling, etc. are all working and the fault is on the G3. I still don’t know whether it’s firmware, hardware, or configuration. I did go carefully through the “System Preferences” -> “Network” control panel to verify the G3 was commanded the same as the G4 (both on OS 10.4.11), with the sole exceptions of: different manual iPv4 address, and different DNS server list (although both have in the list). G4 worked with that setup, G3 did not.

	Next order of business for me is probably net-surfing for G3 firmware upgrade info, then trying to build a USB boot disk and use it. As always suggestions most welcome!
										- Mark

More information about the cctech mailing list