Sun SPARCstation LX boot from CDROM?

Tom Hunter ccth6600 at
Fri Aug 28 11:42:34 CDT 2020

About 20 years ago I rescued a fully working Sun SPARCstation LX with CDROM
and QIC-150 tape drive - all 3 in lunchbox format - plus monitor when we
moved office and management decided they no longer wanted/needed it.

Shortly after I have installed an early version of NetBSD (1.3.3) from the
CDROM drive. I played with it for a few days and then stored the entire
system in a museum grade glass display cabinet. This is indoors with
minimal dust and benign temperatures between 18 degrees C to about 28
degrees C (typical room temperatures here in Perth in Western Australia
unless you run the air conditioner).

Now retired I took the stack of "lunch-boxes" and the CRT monitor out of
the display cabinet and powered it up. After 20 years no smoke came out but
the system didn't boot but reported trouble with the NVRAM setting. I still
could start NetBSD using a "boot disk" command. I googled the problem and
bought and installed a replacement TIMEKEEPER chip (M48T08-100). After
defaulting the settings and setting the MAC address and machine ID it was
happy and booted from disk without intervention. In NetBSD I then set the
date and time and all was good.

Then I decided to upgrade to the latest version of the SPARC version of
NetBSD 9.0. I downloaded and burned the ISO image to CD. Dropped it into a
CD caddy and inserted it into the CDROM drive (SUN Model 411 - really a
Sony CDU-8012 3.1e). I did a "probe-scsi-all" and it found both the hard
drive and the CDROM (target 6 unit 0).

Now comes the problem - if it try to run from it via "boot cdrom" it
doesn't even access the CDROM drive - the LED doesn't turn on unlike when
you do the "probe-scsi-all".

The "cdrom" alias is really: "/iommu/sbus/espdma at 4,8400000/esp at 4
,8800000/sd at 6,0:d".

The "disk" alias is really: "/iommu/sbus/espdma at 4,8400000/esp at 4,8800000/sd at 3,0"

The "@3" versus the "@6" are the SCSI IDs of the disk drive versus the
CDROM. I don't know what the trailing bits mean. I tried cdrom aliases from
"sd at 6,0:0" to "sd at 6,0:f" and all report:

Can't read disk label

Can't open disk label package

Can't open boot device

The LED doesn't blink even once unless I remove and re-insert the caddy
with the CDROM media or if I do a "probe-scsi" or "probe-scsi-all".

I tried original Sun Solaris 2.4 installation media with the exact same

I also tried to access the CDROM from NetBSD using "cat /dev/cd0a" but the
drive's LED didn't blink and I got an obscure error message.

The Boot ROM revision is reported as 2.9. The system was bought about 1985
or 1986 and has seen very little use.

I searched google without success. Maybe I used the wrong search terms or
the equipment is just getting too old and FAQs have disappeared.

What would cause the CDROM boot problem?

There is a chance that the actual Sony drive died. I partially disassembled
it hoping to find dust stuck on the LASER optics but it was nice and clean.
The positioning and ejection mechanisms work just fine. The whole system
was working before I put it into my relatively dust proof glass display

Thanks and best regards

Tom Hunter

More information about the cctech mailing list