DEC Pro 3xx archives

Bjoren Davis bdweb at
Fri Jan 22 10:28:57 CST 2021

I had no problem expanding disk 177-20.

I did it on a Linux system using wteledisk (which I got from using this script:

for d in 
~/downloads/decpro_software/* ; do
     newname=$(basename $d | tr [A-Z] [a-z])
     mkdir decus/$newname
     cd decus/$newname
     for f in $d/*.lzh ; do
     lha -x $f
     for f in *.td0 ; do
     ~/build/wteledsk/src/wteledsk $f -o`basename $f .td0`.dsk
     cd ../..

Here's what the files look like:

$ ls -la build/pos32/decus/pro177/177-20.dsk 
-rw------- 1 user group 409600 May 16  2020 
-rw-r--r-- 1 user group 152827 Oct 22  1993 
$ md5sum build/pos32/decus/pro177/177-20.dsk 
ca88b1d528dab3a5b3c1aaed1dd0f215 build/pos32/decus/pro177/177-20.dsk

Did you possibly download a corrupted copy of 177-20.lzh?


On 1/22/2021 11:09 AM, Warner Losh via cctalk wrote:
> On Fri, Jan 22, 2021 at 8:32 AM Paul Koning <paulkoning at> wrote:
>>> On Jan 21, 2021, at 11:20 PM, Warner Losh <imp at> wrote:
>>> Hey Paul...
>>> This is really helpful. I've had to deal with those archives for the
>> Rainbow stuff I do and have some additional caveats below I thought I'd
>> share...
>> Thanks for that information.
>> Part of my motivation is that I mostly run Mac OS, and after that Linux --
>> not DOS let alone Windows.  So I was hoping to find a Unix solution which
>> is what I documented.
> dosbox runs on macos :).
>> Now I have two additional questions.
>> 1. In the PRO177 collection (P/OS 3.2 base system) the image 177-20 which
>> is the ProSetupV32 disk seems to be bad.  It converts fine, but the
>> converted file is 160k, not 400k as it should be.  If I pad it out with
>> zeroes it still doesn't work, even though the data at the start looks
>> plausible.  Any advice?  Is there a good one somewhere?  Tim Shoppa's copy
>> has the same issue.
> The DEC Robin/VT180 had a format that was 160k long. It's 1 side, 40
> tracks, 8 sectors. Though I can't imagine it being valid in context...
> Have you tried the copies that are at
> ?
> tar tvf 177-20.lzh
> -rw-rw-rw-  0 0      0      245921 Oct 22  1993 177-20.TD0
> which suggests a 'normal' size to me...  Though I've not decoded it, and
> it's possible the original was corrupt somehow...
>> 2. The Xhomer P/OS image has Pro/DECnet installed, it seems, but it
>> doesn't work.  I see the floppies (5 of them) but no information on how to
>> use them.  Any information on Pro/DECnet install and setup anywhere?
> pro175 Pro/DECnet came up in my searches. It's also there. There's a
> pro175.txt that has:
> Following is a list of the manuals you will receive when you
> order Media Service Charge Code (EE):
>   "PRO/DECnet User's Guide"
>   "PRO/DECnet Problem Determination Guide"
> Notes: This program is also included on DECUS No. VS0112.
> Restrictions: A DECNA module is required to use the NET1 port on the
> rear of the system unit.
> Documentation available in hardcopy only. Sources not included.
> though I wasn't able to find it in the usual places, nor by searching for
> AA-V445A-TH which is the document ID number for the first one (I could just
> find references to it).
> Warner

More information about the cctech mailing list