PDP-11/34a hung bus problem.

Noel Chiappa jnc at mercury.lcs.mit.edu
Sat May 14 16:41:10 CDT 2016

    > From Ed Groenenberg

    > - insert both CPU cards, KY11-LB card & bootstrap card, 5 full grant
    > cards, DL11-W  and bus terminator card.
    > ...
    > - cntrl + boot shows register dump at printer.
    > ...
    > All looks ok

I'm surprised the bootstrap ran OK with no memory at all in the machine. I
vaguely STR that I had a machine that would not work like that, but maybe I'm
wrong. (DEC bootstaps tend to do things like set the NXM vector, in low
memory, so they can size memory; and when it gets the NXM (since there is no
memory) from trying to touch the NXM vector, and tries to push the old PS and
PC to service _that_, and gets _another_ NXM, that 'double bus fault' often
causes many -11 processors to do a cheap suit)

    > power down machine, add memory (M7981, 128KW)

What's an M7981? Did you mean an M7891 MS11-L?

    > - power up machine -> run light is on, does not get cleared by
    > cntrl + halt.

This is where a UA11 would really help. I had similar issues with an -11/04,
and the UA11 was a huge help in figuring out what's going on. One glance and
you can see if a bus line is wedged, or something.

    > - power down & replace memory with grand card -> run light is off.

Well, that's good sign - the memory card didn't fry anything, at least...

    > - tried a 2nd memory card (M8722, 128KW)

Ooops. The MS11-M needs +/-12V, which is _not_ standard in most
machines/backplanes). The EUB in the 11/24 and 11/44 (which this card is
intended for) does have it. The really bad part is that those same pins
usually carry +/-15V in most MUD backplanes. So hopefully you didn't fry it.
It does have standard UNIBUS as well as EUB, but there's a jumper, IIRC.

    > So what could be the problem here? The bus works without the memory

Two possibilities off the top of my head. i) The first memory card is bad (or
configured incorrectly), or.. ii) The M7891 uses +/-15V as well as +5V? So
maybe one of the other voltages is not so good? But you said the console
worked, and I think that uses other voltages (at least, in EIA mode - not
sure about 20mA, I never touch the stuff).


More information about the cctalk mailing list