SWTPC 6800 weirdness

Brad H vintagecomputer at bettercomputing.net
Tue Sep 6 13:25:42 CDT 2016

My 6800 has been mostly working, but it seems to be occasionally flaking
out.  I don't know why.  Sometimes you go to power it up, and there's no
response on terminal side.  The 'fix' is sometimes to wiggle the memory/CPU
boards and then for some reason it's fine(ish).  There are five cards
installed right now - the MP-A, MP-S, a heavily modified MP-M board (with
rams piggybacked on all the original RAM chips) and then two Digital
Research 16k boards.  The system was modified for Flex 2.0


Today it flaked again and would not come back up, so I pulled the MP-M board
and the MP-A board and swapped slots.  It came up, but memory at $0100 was
missing.    I tried powering up, swapping slots, etc.. same deal.  Then I
left the machine for an hour, powered up again.. boom.. now $0100 is back.
I don't fully understand the addressing system but if that MP-M is
configured as $A000 would that cover $0100 as well?


I've tried changing the jumpers on each of the DR 16k board to cover $A000..
but the machine will not boot.  I will only work with either the MP-M alone
or those 16k cards with it configured to other spaces.  In other words, the
machine does not accept any other card configured for $A000.


I'm wondering if anyone has any suggestions on how I might nail this down.
I'm thinking some of the RAMs on that MP-M are flaky, but it would be a
*nightmare* to try and diagnose it, with all the RAMs piggybacked, all the
little jumper wires, and everything soldered.  I'd prefer to bypass it and
either use my other, less modified MP-M or just the DR boards, which are
socketed.  If any of you have suggestions on how I might take this MP-M out
of the equation that would be awesome!


More information about the cctalk mailing list